Pod Installation is getting failed everytime

#1

Hi

I am working with the ios project and recently i observed that the pod installation is getting failed every time If someone looking into it please let me know

0 Likes

#2

Hy there, how is it failing? Could you send me the url of the build in which it did, so I can check the logs to see if I can come up with a possible solution?

0 Likes

#3

Hi

Same for me,

I don’t know if it is the same problem but in my case it is the cocoapods-install step that fails without something relevant to know why :

$ gem "install" "cocoapods" "--no-document" "-v" "1.5.3"
Command failed, error: exit status 1

I tried to change my cocoapods version and use the 1.6.1 that is presents by default but same problem happened.

0 Likes

#4
0 Likes

#5

Hy there, based on this github thread, it seems the podspec path is not correct

something like this: https://github.com/mhorowitz/native-navigation-boilerplate/blob/master/ios/Podfile#L12-L14

0 Likes

#6

I do not understand the link between my problem and your solution

  • Everything was working fine on my project last week and starts failing this week without modification on the projet
  • The error seems to be related on the cocoapods gem installation, not on installation of pods

Regards
Sébastien

0 Likes

#7

hy @seb , that was based on @yogeshthanvi’s build log, please send me your build log so I could check that as well

1 Like

#8

Hi

Here is the url of one of my failed builds : https://app.bitrise.io/build/72dea0651a6df9e6

0 Likes

#9

I tried by giving the exact path even its not working, with the same configurations it was working last month and suddenly its not working it seems to be an issue at ur side

0 Likes

#10

Could you try to update your cocoapod version? in your podfile.lock?

0 Likes

#11

Could you please enable support user on the app’s settings tab please?

0 Likes

#12

Hi

I did it yesterday. The build is : https://app.bitrise.io/build/60af36fa06512925

The error is

$ pod "_1.6.1_" "install" "--no-repo-update" "--verbose"
rbenv: version `2.5.0' is not installed (set by /Users/vagrant/git/ios/.ruby-version)
Command failed, error: exit status 1, retrying without --no-repo-update ...
$ pod "_1.6.1_" "repo" "update"
rbenv: version `2.5.0' is not installed (set by /Users/vagrant/git/ios/.ruby-version)
Command failed, error: exit status 1
0 Likes

#13

is there a .ruby-version file in your project? is the rbenv set to 2.5.0 in it? could you change that to 2.5.3?

0 Likes

#14

There is no .ruby-version in my project.

I have to mention that this project was building fine last week and in the same branch without notable modification on the branch it fails this week. Here is a build that succeeds last week : https://app.bitrise.io/build/2add65b76b9d1821

0 Likes

#15

I found the only difference that could cause the step to fail
47
this is the one that succeeded with cocoapods version 1.5.3

54
and this one failed with 1.6.1, sooo I guess you should set the cocoapods version to 1.5.3 in your podfile.lock :thinking:

0 Likes

#16

Hi

To summarize my problem

I apologize because I just realized that I have a .ruby-version file in my project. Maybe there was a modification on the ruby version on bitrise last week and this explain why my step fail.

I will try to remove my .ruby-version file to see if it solves the problem.

Regards
Sebastien

0 Likes

#17

yes the cocoapod version update was indeed on our end

0 Likes

closed #18

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes