React native 0.64 build failing due to outdated cocoapods version

react-native
#1

We are trying to upgrade our application to React Native 0.64 and we have an issue with the cocoa-pods installation since the minimum required version for react now is 1.10.1 and all Mac stacks on bitrise use 1.10.0. This is an issue for us and potentially others who are using bitrise for react native builds.

Off-course we can mitigate the issue by running a script with sudo gem install cocoapods before cocoa-pods install, but it should be done on bitrise side.

Can this be addressed or should this be a feature request?

Environment:

  • Visual studio for mac stable channel
  • Cocoapods install step, Version: 2.1.0

Build log


CocoaPods 1.10.1 is available.
To update use: `gem install cocoapods`

For more information, see https://blog.cocoapods.org and the CHANGELOG for this version at https://github.com/CocoaPods/CocoaPods/releases/tag/1.10.1

//...

[!] `React` requires CocoaPods version `>= 1.10.1`, which is not satisfied by your current version, `1.10.0`.
3 Likes

#2

Is there any word on this from the bitrise team?

0 Likes

#3

Hello there everyone!

I wanted to let you know that although there is no current ETA to when this will happen, I can confirm that this is already in our developers backlog.
Not sure when this will be addressed, but hopefully you can update your Cocoapods manually in the meantime! :slight_smile:

0 Likes