React native 0.64 build failing due to outdated cocoapods version

We are trying to upgrade our application to React Native 0.64 and we have an issue with the cocoa-pods installation since the minimum required version for react now is 1.10.1 and all Mac stacks on bitrise use 1.10.0. This is an issue for us and potentially others who are using bitrise for react native builds.

Off-course we can mitigate the issue by running a script with sudo gem install cocoapods before cocoa-pods install, but it should be done on bitrise side.

Can this be addressed or should this be a feature request?


  • Visual studio for mac stable channel
  • Cocoapods install step, Version: 2.1.0

Build log

CocoaPods 1.10.1 is available.
To update use: `gem install cocoapods`

For more information, see and the CHANGELOG for this version at


[!] `React` requires CocoaPods version `>= 1.10.1`, which is not satisfied by your current version, `1.10.0`.

Is there any word on this from the bitrise team?

Hello there everyone!

I wanted to let you know that although there is no current ETA to when this will happen, I can confirm that this is already in our developers backlog.
Not sure when this will be addressed, but hopefully you can update your Cocoapods manually in the meantime! :slight_smile:

Backlog tickets can stay forever there, this is an urgent matter!

+1 for also running into this issue and it being urgent.

I even tried adding a brew-install step to (re)install the latest version of Cocoapods before moving on:

Run brew command
$ brew "reinstall" "cocoapods"
Warning: Treating cocoapods as a formula. For the cask, use homebrew/cask/cocoapods
==> Downloading
==> Downloading from
==> Reinstalling cocoapods 
==> Pouring cocoapods-1.10.1.catalina.bottle.tar.gz
🍺  /usr/local/Cellar/cocoapods/1.10.1: 13,132 files, 30.4MB
|                                                                              |
| ✓ | brew-install@0                                                | 42.10 sec|

Yet after this step’s success, I still get the OP’s error when installing pods:

Fetching podspec for `glog` from `../node_modules/react-native/third-party-podspecs/glog.podspec`
[!] `React` requires CocoaPods version `>= 1.10.1`, which is not satisfied by your current version, `1.10.0`.
Yarn command failed, error: exit status 1

@Roland-Bak Could you extrapolate, in the context of Bitrise, how to go about implementing your suggestion of:

…hopefully you can update your Cocoapods manually in the meantime


:wave: @Roland-Bak Any update here?

I figured out to simply add a script to the setup workflow I have:

#!/usr/bin/env bash

gem install cocoapods
rbenv rehash

Solves this issue.

1 Like

Glad to hear you’ve found the solution @wkoutresg! The Cocoapods version bump requested originally was done on April 28th.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.