Pod install failed: No such file or directory @ rb_sysopen

step
ios
#1

Report

  • What did you do?
    build step: cocoapods-install

command

/Users/vagrant/.rbenv/versions/2.6.5/bin/pod install --verbose
  • What did you expect to happen?
    pod install complete

  • What happened instead?
    an error occurred as below.
    pod install works in local.

Error

Errno::ENOENT - No such file or directory @ rb_sysopen - /Users/vagrant/git/DatingApp/Pods/BoringSSL-GRPC/src/include/openssl/BoringSSL.modulemap
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/installer/xcode/pods_project_generator/pod_target_installer.rb:962:in `read'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/installer/xcode/pods_project_generator/pod_target_installer.rb:962:in `read'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/installer/xcode/pods_project_generator/pod_target_installer.rb:962:in `block in create_module_map'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/user_interface.rb:145:in `message'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/installer/xcode/pods_project_generator/pod_target_installer.rb:961:in `create_module_map'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/installer/xcode/pods_project_generator/pod_target_installer.rb:78:in `block in install!'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/user_interface.rb:145:in `message'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/installer/xcode/pods_project_generator/pod_target_installer.rb:40:in `install!'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/installer/xcode/pods_project_generator.rb:115:in `block in install_pod_targets'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/installer/xcode/pods_project_generator.rb:112:in `map'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/installer/xcode/pods_project_generator.rb:112:in `install_pod_targets'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/installer/xcode/single_pods_project_generator.rb:32:in `block in install_all_pod_targets'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/user_interface.rb:145:in `message'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/installer/xcode/single_pods_project_generator.rb:31:in `install_all_pod_targets'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/installer/xcode/single_pods_project_generator.rb:19:in `generate!'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/installer.rb:312:in `block in create_and_save_projects'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/user_interface.rb:64:in `section'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/installer.rb:307:in `create_and_save_projects'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/installer.rb:299:in `generate_pods_project'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/installer.rb:178:in `integrate'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/installer.rb:166:in `install!'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/command/install.rb:52:in `run'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/claide-1.0.3/lib/claide/command.rb:334:in `run'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/lib/cocoapods/command.rb:52:in `run'
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.10.0/bin/pod:55:in `<top (required)>'
/Users/vagrant/.rbenv/versions/2.6.5/bin/pod:23:in `load'
/Users/vagrant/.rbenv/versions/2.6.5/bin/pod:23:in `<main>'

Log before occuring the error

Generating Pods project
  - Creating Pods project
  - Installing files into Pods project
    - Adding source files
    - Adding frameworks
    - Adding libraries
    - Adding resources
    - Linking headers
  - Installing Pod Targets
    - Installing target `BoringSSL-GRPC` iOS 8.0
      - Copying module map file to `Pods/Target Support Files/BoringSSL-GRPC/BoringSSL-GRPC.modulemap`

Stack

   CocoaPods : 1.10.0
        Ruby : ruby 2.6.5p114 (2019-10-01 revision 67812) [x86_64-darwin19]
    RubyGems : 3.0.3
        Host : Mac OS X 10.15.7 (19H2)
       Xcode : 12.1.1 (12A7605b)
         Git : git version 2.29.2
Ruby lib dir : /Users/vagrant/.rbenv/versions/2.6.5/lib
Repositories : master - git - https://github.com/CocoaPods/Specs.git @ b2b4a845cc76b9b7805593d452bca08e1db09066
               trunk - CDN - https://cdn.cocoapods.org/

Plugins

cocoapods-deintegrate : 1.0.4
cocoapods-plugins     : 1.0.0
cocoapods-search      : 1.0.0
cocoapods-trunk       : 1.5.0
cocoapods-try         : 1.2.0
slather               : 2.5.0

Podfile

# Uncomment the next line to define a global platform for your project
platform :ios, '13.0'
target 'DatingApp' do
  # Comment the next line if you're not using Swift and don't want to use dynamic frameworks
  use_frameworks!

  # Firebase
  pod 'Firebase/Core', '~> 7.0'
  pod 'Firebase/Auth', '~> 7.0'
  pod 'Firebase/Messaging', '~> 7.0'
  pod 'Firebase/Storage', '~> 7.0'
  pod 'Firebase/Firestore', '~> 7.0'
  pod 'FirebaseFirestoreSwift', '~> 7.0.0-beta'
  pod 'Firebase/Analytics', '~> 7.0'
  pod 'Firebase/Functions', '~> 7.0'
  pod 'Firebase/Crashlytics', '~> 7.0'
  pod 'FirebaseUI/Storage', '~> 9.0'
  pod 'GoogleIDFASupport'

#Pods for Podtest
  #Dev Environment
end
0 Likes

#2

Hi @popai306
Can you confirm that your podfiles exist in your project?
Can you also try to install the podfiles again after deleting the existing one, if it does exist?

Thanks
Chaitanya

0 Likes

#3

I tried to rm -rf Pods/, then pod install success!
Thank you for supporting!

0 Likes

#4

Hi @popai306
I am glad I was able to help you resolve your issue.

Thanks
Chaitanya

0 Likes