Pod install failed on iOS build

#1

I never facing this problem before just today I getting error when install dependency in iOS

It error every build on “pod install” cocoapods-install@1.10

then I try to update to 1.11 it still getting error

Environment:

Xcode 11.3.x, on macOS 10.14.6 (Mojave)

Which build Step causes the issue and which version of the step?
Step run cocoapod install

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) :
    NO

  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : YES/NO

  • Does the issue happen sporadically, or every time? :Every time

  • Does upgrading the build Step to the latest version help? : NO

  • When did the issue start? :18May2020

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

It work normally on my local Machine

Build log

$ pod “install” “–verbose”
Preparing
Analyzing dependencies
Inspecting targets to integrate
Using ARCHS setting to build architectures of target Pods-dtac-iservice: () Using `ARCHS` setting to build architectures of target `Pods-beta`: ()
Using ARCHS setting to build architectures of target Pods-dtac-iserviceTests: () Using `ARCHS` setting to build architectures of target `Pods-dtacUITests`: ()
Resolving dependencies of Podfile
Comparing resolved specification to the sandbox manifest
A AFNetworking
A Alamofire
A AlamofireImage
A BEMCheckBox
A Bolts
A BzbsXDtacSDK
A CNPPopupController
A Charts
A Crashlytics
A DACircularProgress
A DCPathButton
A DTEllipseButton
A DXPopover
A ESPullToRefresh
A FBAudienceNetwork
A FBSDKCoreKit
A FBSDKLoginKit
A FLAnimatedImage
A FLEX
A FXBlurView
A Fabric
A Firebase
A FirebaseABTesting
A FirebaseAnalytics
A FirebaseAnalyticsInterop
A FirebaseAuthInterop
A FirebaseCore
A FirebaseCoreDiagnostics
A FirebaseCoreDiagnosticsInterop
A FirebaseDatabase
A FirebaseDynamicLinks
A FirebaseInAppMessagingDisplay
A FirebaseInstallations
A FirebaseInstanceID
A FirebaseMessaging
A FirebasePerformance
A FirebaseRemoteConfig
A GTMSessionFetcher
A GoogleAnalytics
A GoogleAppMeasurement
A GoogleDataTransport
A GoogleDataTransportCCTSupport
A GoogleMaps
A GooglePlaces
A GoogleTagManager
A GoogleToolboxForMac
A GoogleUtilities
A HACBarChart
A HCSStarRatingView
A HMSegmentedControl
A IDMPhotoBrowser
A IGListKit
A ISO8601-re2c
A ImageSlideshow
A InfiniteCarouselCollectionView
A JVFloatLabeledTextField
A KLCPopup
A KVOController
A Kingfisher
A LCBannerView
A MMDrawerController
A MPCoachMarks
A OAStackView
A OHHTTPStubs
A PopMenu
A PromisesObjC
A Protobuf
A PureLayout
A Realm
A SDWebImage
A SSKeychain
A SVProgressHUD
A SVPullToRefresh
A TMCache
A TOMSMorphingLabel
A UICountingLabel
A VBFPopFlatButton
A VENTouchLock
A WSCoachMarksView
A WZLBadge
A WebViewJavascriptBridge
A WootricSDK
A XHRealTimeBlur
A YHRoundBorderedButton
A dtac-promo
A iCarousel
A leveldb-library
A lottie-ios
A nanopb
A pop
A vfrReader
Downloading dependencies
-> Installing AFNetworking (3.0.4)

Copying AFNetworking from /Users/vagrant/Library/Caches/CocoaPods/Pods/Release/AFNetworking/3.0.4-a0075 to Pods/AFNetworking
-> Installing Alamofire (4.9.0)
Copying Alamofire from /Users/vagrant/Library/Caches/CocoaPods/Pods/Release/Alamofire/4.9.0-afc3e to Pods/Alamofire
-> Installing AlamofireImage (3.6.0)
Copying AlamofireImage from /Users/vagrant/Library/Caches/CocoaPods/Pods/Release/AlamofireImage/3.6.0-be996 to Pods/AlamofireImage
-> Installing BEMCheckBox (1.4.1)
Copying BEMCheckBox from /Users/vagrant/Library/Caches/CocoaPods/Pods/Release/BEMCheckBox/1.4.1-5ba6e to Pods/BEMCheckBox
-> Installing Bolts (1.9.1)
Copying Bolts from /Users/vagrant/Library/Caches/CocoaPods/Pods/Release/Bolts/1.9.1-8c1e8 to Pods/Bolts
-> Installing BzbsXDtacSDK (1.1.17)
Copying BzbsXDtacSDK from /Users/vagrant/Library/Caches/CocoaPods/Pods/Release/BzbsXDtacSDK/1.1.17-f2cb2 to Pods/BzbsXDtacSDK
-> Installing CNPPopupController (0.3.3)
Copying CNPPopupController from /Users/vagrant/Library/Caches/CocoaPods/Pods/Release/CNPPopupController/0.3.3-59b06 to Pods/CNPPopupController
-> Installing Charts (3.4.0)
Copying Charts from /Users/vagrant/Library/Caches/CocoaPods/Pods/Release/Charts/3.4.0-74c9f to Pods/Charts
-> Installing Crashlytics (3.12.0)
Copying Crashlytics from /Users/vagrant/Library/Caches/CocoaPods/Pods/Release/Crashlytics/3.12.0-07fb1 to Pods/Crashlytics
-> Installing DACircularProgress (2.3.1)
Copying DACircularProgress from /Users/vagrant/Library/Caches/CocoaPods/Pods/Release/DACircularProgress/2.3.1-4dd43 to Pods/DACircularProgress
-> Installing DCPathButton (2.1.4)
Copying DCPathButton from /Users/vagrant/Library/Caches/CocoaPods/Pods/Release/DCPathButton/2.1.4-99c82 to Pods/DCPathButton
-> Installing DTEllipseButton (0.0.12)
Copying DTEllipseButton from /Users/vagrant/Library/Caches/CocoaPods/Pods/Release/DTEllipseButton/0.0.12-c6449 to Pods/DTEllipseButton
-> Installing DXPopover (0.1.1)
Copying DXPopover from /Users/vagrant/Library/Caches/CocoaPods/Pods/Release/DXPopover/0.1.1-13e6b to Pods/DXPopover
-> Installing ESPullToRefresh (2.9.2)
Copying ESPullToRefresh from /Users/vagrant/Library/Caches/CocoaPods/Pods/Release/ESPullToRefresh/2.9.2-efed0 to Pods/ESPullToRefresh
-> Installing FBAudienceNetwork (4.28.1)
Http download
$ /usr/bin/curl -f -L -o /var/folders/6q/wgy6jtp12w5gzgm9lzcglpqw0000gn/T/d20200518-2765-1j8r9we/file.zip https://developers.facebook.com/resources/FBAudienceNetwork-4.28.1.zip --create-dirs --netrc-optional --retry 2
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed

 0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
 0     0    0     0    0     0      0      0 --:--:--  0:00:01 --:--:--     0
 0     0    0     0    0     0      0      0 --:--:--  0:00:01 --:--:--     0

Warning: Transient problem: HTTP error Will retry in 1 seconds. 2 retries
Warning: left.

 0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
 0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
 0     0    0     0    0     0      0      0 --:--:--  0:00:01 --:--:--     0

Warning: Transient problem: HTTP error Will retry in 2 seconds. 1 retries
Warning: left.

 0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
 0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0

curl: (22) The requested URL returned error: 500
[!] Error installing FBAudienceNetwork
[!] /usr/bin/curl -f -L -o /var/folders/6q/wgy6jtp12w5gzgm9lzcglpqw0000gn/T/d20200518-2765-1j8r9we/file.zip https://developers.facebook.com/resources/FBAudienceNetwork-4.28.1.zip --create-dirs --netrc-optional --retry 2
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:01 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:01 --:–:-- 0
Warning: Transient problem: HTTP error Will retry in 1 seconds. 2 retries
Warning: left.

0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:01 --:–:-- 0
Warning: Transient problem: HTTP error Will retry in 2 seconds. 1 retries
Warning: left.

0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
curl: (22) The requested URL returned error: 500
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/downloader.rb:142:in rescue in execute_command' /Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/downloader.rb:139:inexecute_command’
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-downloader-1.3.0/lib/cocoapods-downloader/base.rb:154:in block in executable' /Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-downloader-1.3.0/lib/cocoapods-downloader/http.rb:18:indownload_file’
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-downloader-1.3.0/lib/cocoapods-downloader/remote_file.rb:25:in download!' /Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-downloader-1.3.0/lib/cocoapods-downloader/base.rb:82:inblock in download’
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/downloader.rb:157:in block in ui_action' /Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/user_interface.rb:64:insection’
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/downloader.rb:156:in ui_action' /Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-downloader-1.3.0/lib/cocoapods-downloader/base.rb:80:indownload’
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/downloader.rb:108:in download_source' /Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/downloader.rb:75:indownload_request’
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/downloader/cache.rb:171:in download' /Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/downloader/cache.rb:154:inblock in uncached_pod’
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/downloader/cache.rb:181:in in_tmpdir' /Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/downloader/cache.rb:153:inuncached_pod’
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/downloader/cache.rb:33:in download_pod' /Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/downloader.rb:42:indownload’
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/installer/pod_source_installer.rb:117:in download_source' /Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/installer/pod_source_installer.rb:69:ininstall!’
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/installer.rb:557:in install_source_of_pod' /Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/installer.rb:508:inblock (2 levels) in install_pod_sources’
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/user_interface.rb:86:in titled_section' /Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/installer.rb:507:inblock in install_pod_sources’
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/installer.rb:490:in each' /Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/installer.rb:490:ininstall_pod_sources’
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/installer.rb:248:in block in download_dependencies' /Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/user_interface.rb:64:insection’
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/installer.rb:247:in download_dependencies' /Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/installer.rb:157:ininstall!’
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/command/install.rb:52:in run' /Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/claide-1.0.3/lib/claide/command.rb:334:inrun’
/Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/lib/cocoapods/command.rb:52:in run' /Users/vagrant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/cocoapods-1.8.4/bin/pod:55:in<top (required)>’
/Users/vagrant/.rbenv/versions/2.6.5/bin/pod:23:in load' /Users/vagrant/.rbenv/versions/2.6.5/bin/pod:23:in
Command failed, error: exit status 1
| |
±–±--------------------------------------------------------------±---------+
| x | cocoapods-install@1.11 (exit code: 1) | 2.4 min |
±–±--------------------------------------------------------------±---------+
| Issue tracker: https://github.com/bitrise-io/steps-cocoapods-install/issues |
| Source: https://github.com/bitrise-io/steps-cocoapods-install |
±–±--------------------------------------------------------------±---------+

0 Likes