Npm "test" fails

#1

Bitrise Build Issue Report template

Description of the issue

When we run our build we get:
Running user provided command
$ npm “test”
Error running command test: error running npm command: exit status 1

Environment:

Bitrise react-native

Which build Step causes the issue and which version of the step?

npm@1.0.1

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : Every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : First time we ran the build.

Local reproduction

_Can it be reproduced on your own Mac/PC by following our [local debug guide]? NO

Build log

0 Likes

#2

Hello there! Could you enable support user on the settings tab? I would like to check out some setups, and run some test builds if it is okay with you.

0 Likes

#3

I already did.

0 Likes

#4

Hi @tom.isaacson,

Sorry for the delay on this! The latest support-testing build was failed due to the following error message: No tests found, exiting with code 1 Is it possible that somehow your tests in the repository are ignored? You can see the detailed logs in the latest build.

0 Likes

closed #5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes