NPM step fails on fetching dependency from PRIVATE git repo via SSH

gitlab
npm
#1

Bitrise Build Issue Report template

Description of the issue

NPM step started to fail on fetching dependency from PRIVATE git repo via SSH

npm ERR! Error while executing:
npm ERR! /usr/bin/git ls-remote -h -t git@gitlab.srv.***:***.git
npm ERR! No user exists for uid 1000
npm ERR! fatal: Could not read from remote repository.
npm ERR! Please make sure you have the correct access rights
npm ERR! and the repository exists.
npm ERR! exited with error code: 128

Environment:

Where did the issue happen?

Android & Docker, on Ubuntu 16.04

Which build Step causes the issue and which version of the step?

Run npm command v1.1.0, Do anything with Script step v1.1.5

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : ~ last month

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Testing with a full clean git clone: NOT REPRODUCED
Test with the Bitrise CLI: NOT REPRODUCED

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ .

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - https://www.bitrise.io/contact ), with a link to the related Discuss issue.

0 Likes

#2

Hi there! :wave:

I’m really sorry about the delay in getting to your issue. We are currently migrating to a new system in order to be able to assist you better in the future.

Due to the considerable delay please let us know if your issue still requires investigation; please send us a short message confirming this, send us a more recent build URL and allow Support Access.

Again, apologies for the delay, going forward we’ll do our best to offer quicker replies. Thanks!

0 Likes

#3

Issue still exists. Here is the link to the latest build https://app.bitrise.io/build/3a3f6d546981b6ae#?tab=log. Support Access enabled. Thank you.

0 Likes