SPM & Github Enterprise Private Repo via SSH

ios
#1

Bitrise Build Issue Report template

Description of the issue

We have a variety of third party dependencies that we pull in via SPM. However, when I attempt to add a new dependency hosted in a private Github Enterprise repo via SSH bitrise fails the build. When I run locally through Xcode everything is lovely. Going through the logs of bitrise shows that it is attempting to use HTTPS instead of SSH. The project file clearly shows the SSH url is specified.

Environment:

Where did the issue happen?

Xcode 12.4.X

Which build Step causes the issue and which version of the step?

ios-auto-provision-appstoreconnect
version: 1.0.3
collection: https://github.com/bitrise-io/bitrise-steplib.git

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO

  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO

  • Does the issue happen sporadically, or every time? : Every time

  • Does upgrading the build Step to the latest version help? : NO

  • When did the issue start? : Since we’ve added this new dependency. It has never worked through bitrise. Runs completely fine through Xcode build locally.

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - https://www.bitrise.io/contact ), with a link to the related Discuss issue.

1 Like