Not able to take build after cert change

#1

Bitrise Build Issue Report template

Description of the issue

I have renewed the cert and profile and i have uploaded it to Bitrise. We usually take two build, one for USA country and one for CA country. USA build is success but CA build is failed because of profile issue

“error: No profile for team ‘WDM568A6W8’ matching ‘Beauty Systems Group LLC Stylist CA Distribution’ found: Xcode couldn’t find any provisioning profiles matching ‘WDM568A6W8/Beauty Systems Group LLC Stylist CA Distribution’. Install the profile (by dragging and dropping it onto Xcode’s dock item) or select a different one in the General tab of the target editor. (in target ‘Stylist-CA’)”

Environment:

PROD

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? (Plus any other information you can share)

Step - id: xcode-archive, version: 2.4.15

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. NO (I didn’t use caching)
  • Does the issue happen sporadically, or every time? : Everytime
  • Does upgrading the build Step to the latest version help? : I didn’t try
  • When did the issue start? : 28 Oct 2019

Local reproduction

I able to take local build in XCode or Mac machine

Build log

Build - 3079:


Build - 3080:

Build-3083:

Attached image for evidence i have profile installed in Bitrise. Please let me know if you have any questions.

Thanks,
Sathish

0 Likes

#2

Resolved this issue

For CA target, I am not able to see same provisioning profile in Apple developer portal and Source Code. I see different name for provisioning profile between Apple developer portal and Source Code. Old provisioning profile is not listed in Apple developer portal and I renewed provisioning profile which is available in Apple developer portal(and uploaded in Bitrise) but same name is not configured in Source code. We find this issue then I changed the name of provisional profile and build in Bitrise is successful. Thanks for the help anyways.

Thanks,
Sathish

0 Likes