Uploading Profiles and Certificates with API During Build - Build FAILS to pick them up

ios
#1

Description of the issue

So I wanted to make multiple builds for different apps - I’ve written a bash script which hooks into the Bitrise API to upload the needed provisioning profiles and certificates which is provided by a json I made.

When I build, the script step works, the profiles and certificates get uploaded, however the build fails the first time (I’m not sure if this is because the archiving step cannot find the newly updated profiles and certs…?) When I re-build it, it can then find them.

I’ve found out that the certificate and profile installer step fails to pick up the newly added profiles and certs from the script step above.

I’ve also tried running a script which uploads the certs in a workflow above which then runs the main workflow right after…this didn’t work either.

The goal is to be able to upload new certs and profiles in the build phase all managed by a json feed.
I’d also like to ask if there is a delete all profiles and certs in the API section? I tried to do this: curl -X DELETE 'Authorization: THE-ACCESS-TOKEN' 'https://api.bitrise.io/v0.1/apps/APP-SLUG/provisioning-profiles' but didn’t work.

Environment:

It fails on the xocde-archive step

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : YES - As it can now read the new profiles / certs
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : Everytime I re-install the profiles / certs
  • Does upgrading the build Step to the latest version help? : NO

Build log

0 Likes