Keystore was tampered with, or password was incorrect

#1

Bitrise Build Issue Report template

Description of the issue

Running the app sign phase, I’m having the following issue:
Failed to create keystore helper, error: [keytool error: java.io.IOException: Keystore was tampered with, or password was incorrect

Environment:

Where did the issue happen?

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? (Plus any other information you can share)

Which build Step causes the issue and which version of the step?

| (11) sign-apk |
±-----------------------------------------------------------------------------+
| id: sign-apk |
| version: 1.7.2 |
| collection: https://github.com/bitrise-io/bitrise-steplib.git |
| toolkit: go |
| time: 2020-11-14T23:45:17Z

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : YES/NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : YES/NO
  • Does the issue happen sporadically, or every time? : NO
  • Does upgrading the build Step to the latest version help? : YES/NO
  • When did the issue start? : Today (2020-11-14)

Local reproduction

Haven’t tried

Local reproduction: Linux / Android (docker based) stack builds

Haven’t tried

Build log

0 Likes

#2

Hi @jquin_ag, can you enable Support User access for us on this project? :slight_smile:

0 Likes

#3

Hi bitce!

Someone changed the password, that was the reason. :confused:

Thanks for your support

1 Like