APK signing failed - Issue with input: [no KeystoreURL parameter specified]

Bitrise Build Issue Report template

Description of the issue

We are preparing our app for Google Play Store submission so we uploaded a new keystore file to Bitrise. Suddenly the Sign APK started failing with the error: Issue with input: [no KeystoreURL parameter specified]

We uploaded the keystore file to the Android keystore file section in the Code Signing tab.

Previously this worked perfectly.


Where did the issue happen?

Hybrid stack, with both Android tools and Xcode 8

Which build Step causes the issue and which version of the step?

Sign APK 1.2.0


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : Every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : Today, when we uploaded a new keystore file

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ .

Build log


Hey @airmiha!

Sorry for the inconvenience, this issue is just resolved in the last couple of minutes. A simple re-build should work just fine.

Please let us know if you still encounter any issues with it! :blush:

1 Like

Hey @tamaspapik, it works now :). Thanks!