ITMS-90034: Missing on invalid signature

Sorry no time to file a proper issue report.

I’ve set up my CI for my iOS app in november and has been running fine until today.
I’ve deployed 140 successful builds to Testflight with the same setup, but it broke yesterday for some reason.

My builds are completing fine and uploading iOS builds to Testflight.
However Apple cannot validate my builds saying:

Dear Developer,

We identified one or more issues with a recent delivery for your app, “Appname” 1.4.1 (140). Please correct the following issues, then upload again.

ITMS-90034: Missing on invalid signature
The bundle com.mycompany.appname at bundle path Payload/Appname.app` is not signed using an Apple submission certificate.

(appname and mycompany is used for privacy reasons.)

Double checked my certificates and they are valid until 2020 Oct 4, and no change has been made in the past 6 months.
Bitrise says my certificates are valid as well, nothing suspicious is reported in the Bitrise console.

To me this seems to be a change on Apple’s side, I can redo my certificate signing settings, however I think it’s best to ask the Bitrise team to investigate as this might come up for more users.

Any suggestions why the above error might occur seemingly out of the blue?

Thanks.

2 Likes

We were running into this issue earlier today. We retried the build again and App Store Connect just finished processed the build, so the issue might be fixed now.

1 Like

I have same issue today. I tried to upload new build today. I changed nothing until last upload actually. After upload my app I got email with message following:

ITMS-90034: Missing or invalid signature - The bundle ‘com.myapp’ at bundle path ‘Payload/MyApp.app’ is not signed using an Apple submission certificate.

I tried several times with different bundle numbers. Not solved yet.

I got my issue resolved by running the build today.
I didn’t change my bundle version just let Bitrise increment my build number as usual and the app has been verified by Apple without any issues.

I think it’s an Apple bug, I’d suggest if your setup was working before just keep trying.

Here’s a thread regarding this issue in Apple Developer Forums: https://forums.developer.apple.com/thread/133781

We have the same issues +1

1 Like

Hello,

Thank you so much for taking the time to report this issue! Our engineers are currently taking a look to see what might be causing this.
We will update you here as soon as we have more information.

Thank you for your patience!

Hello,

Our engineers looked into this and it is more likely that the issue is on Apple’s end as other CI/CD providers seem to be affected as well.

Do you get the same issue when you upload your app to App Store Connect from your local computer?

Someone on the forum reported that this resolved the issue for them:

I received from Apple’s support the suggestion to remove the revoked certificates from Keychain, leaving only the current one, which is valid (I did a backup just before deleting the old certificates).

After that I retried and the upload was succesful.

I was wondering if you could give this suggestion a try. We are monitoring and investigating this issue, but it appears to be on Apple’s end. There are posts with suggestions from Apple and other users you may want to try here: https://forums.developer.apple.com/thread/133781

Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.