iOS - PRODUCT_BUNDLE_IDENTIFIER is missing

Hi all,
I updated my Xcode to 8.3 last Friday. Since now, I can’t launch a build, I have an error in stack “Xcode Archive for iOS”. It’s say that PRODUCT_BUNDLE_IDENTIFIER is missing but I see it in the plist.
Same for development team.

Hi @appaloosa.project,

Do you generate the Info.plist or similar during the build? It seems like an issue there.
To be honest we didn’t see this error with any of our samples, which use standard Xcode project (no auto generated files), so we’ll probably need a bit more info.

1 Like

Hi Viktor,
I figured out my issue, the error wasn’t because of the stack, there is an “&” character in an argument name which generate the error. I don’t know why bitrise tells me that the PRODUCT_BUNDLE_IDENTIFIER is missing, because when I delete the “&” character it’s working well :sweat:
Thanks again for your answer :slight_smile:

1 Like

Glad to hear you could resolve the issue, just one note, if you got that error in the Xcode Archive step then it’s not Bitrise telling you there’s an issue with the bundle identifier, it’s Xcode. You could run the same commands locally one by one and would get the same error.

Running the build locally with our CLI can help to speed up the testing in these cases, just for future reference (in case someone else would face a similar issue) : How to debug your build locally / "It works on my Mac/PC but not on bitrise.io"

Happy Building! :blush:

1 Like

@viktorbenei, I am getting following:

Code Signing Error: Bundle identifier is missing. nintendoapp doesn’t have a bundle identifier for the Release build configuration. Add a value for PRODUCT_BUNDLE_IDENTIFIER in the build settings editor.
Code Signing Error: Code signing is required for product type ‘Application’ in SDK ‘iOS 11.2’

I tried to recollect certificates and provision profile files and it does not help. I have bundle identifier in info.plist (as variable) also in the project.pbxproj PRODUCT_BUNDLE_IDENTIFIER = “my.app.name”; and it works smoothly in the xcode build. on my mac.

Do you know what it should be? The build worked before, it just happened now after some time.

Kinds,
Nik

Can you please run our codesigndoc tool on your Mac after you do an Archive + Export, to ensure it indeed works, with the same configs you try to build on bitrise.io?

Just follow this guide: https://devcenter.bitrise.io/ios/code-signing/#collect-the-required-files-with-codesigndoc , run the one-liner and upload all the files it generates/collect to bitrise.io, that should help! :wink: If it would not, then please fill out a new #issues:build-issues report so that we have all the infos required to help you as efficiently & quickly as possible! :wink:

Hi Viktor!

I tried it for sure with codesigndoc (created new p12 + other certificate, uploaded and restarted build), but still getting the same error. Anyway, what should I provide you that you test it out and check why it does not work? If you want I can send you the log and maybe yml if you want.

Kinds,
Nik

Hi @nadzic,

Please contact our support via the onsite chat, or fill out a #issues:build-issues report :slight_smile:

This topic was automatically closed after 13 days. New replies are no longer allowed.