Issue with APIToken: parameter not specified (Virtual Devices)

android
#1

I’m using this yml, following the steps, but I keep having that error when I try to run the virtual devices tests:

    steps:
    - cache-pull@2.0.1: {}
    - install-missing-android-tools@2.3.5:
        inputs:
        - gradlew_path: "./gradlew"
    - android-lint@0.9.6:
        inputs:
        - variant: devRelease
    - android-unit-test@0.9.6:
        inputs:
        - gradle_file: "$GRADLE_BUILD_FILE_PATH"
        - gradle_task: assembleDebug
        - variant: devRelease
        - gradlew_path: "$GRADLEW_PATH"
    - gradle-runner@1.8.4:
        inputs:
        - gradle_task: assembleDevRelease assembleDevReleaseAndroidTest
    - cache-push@2.1.0: {}
    - virtual-device-testing-for-android@1.0.5:
        inputs:
        - test_type: instrumentation

Any ideas?

I declared the testBuildType “debug”/“release” and I’m able to run my androidTest on my machine, also able to assemble it on my local and at Bitrise.

0 Likes

#2

Hello there, Could you please send us the url of a failing build, so we could check out the full logs to it and try to come up with a possible solution? :upside_down_face:

0 Likes

#3

just found the reason, the problem is a setting, the virtual devices got disabled at some point, and the message wasn’t really pointing why I could not get the token anymore, thanks!

1 Like

#4

Sounds great, I’m glad you found a solution!!

0 Likes