Issue with APIBaseURL: parameter not specified

I’m trying to run android build with UI tests.
I cannot make the build start the emulator.
I’m getting “Issue with APIBaseURL: parameter not specified”
What is APIBaseURL ? where should it be set up ?

1 Like

Hi @snpori,

Sorry for the delay.

Did you enable Virtual Device Testing for this app?

If you enable that feature (Virtual Device Testing on the Settings tab of the app) that will specify this API URL.

Thanks for your help.
I added the virtual device in the settings however that lead me to another error:
“Issue with ApkPath: parameter not specified”

I’m sorry for having to go baby steps with this however it’s not always clear what are those variables and where are they defined in bitrise;s workflow.


Please follow the setup guide at

If you’d have any questions just let me know! :wink:

I have the same issue (“Issue with APIBaseURL: parameter not specified”) if Im running the virtual device tests locally on my mac with bitrise cli. Is this build step designed to run on cli?

Thx, Alex

Hi @alexknauf !

No, sadly you can’t use the “Virtual Device Testing” step on CLI only in Bitrise.
The step.yml should have the "run_if: ".IsCI" flag but it doesn’t have.

I have created a ticket for the tooling team to add it to the step.yml

1 Like