iOS Auto Provision v1.0.0

@MattCheetham it seems the step is able to determine your scheme target’s bundle id.

Then the step tries to ensure the app-store and development type Provisioning Profile for this target.
The development target’s Profile seems to be existing on Developer Portal and it downloads successfully,
but it does not find the app-store Profile on Developer Portal.

This can happen if you did not generated the app-store profile yet, this means you never exported an app-store type ipa file in your local xcode, by using managed Profiles.

Is it possible?

1 Like

@matthias.buchetics it seems you did not upload any development type codesign identity, thats why the step can not ensure the existence of your development profile and xcode missis this file:

Xcode couldn't find any iOS App Development provisioning profiles matching ''.

Please upload your development type codesign identity, which you use locally for Xcode managed signing.

Other then this the step finds your enterprise profile and installs it, when you upload the extra certificate it should work.

1 Like

We are also having an issue with the latest version of auto-provision step not being able to find the bundle id. Before today this was working fine.

The project had the client bundle identifier, and “automatically manage signing” checked, and the team set to the client. Then we use the “Replaces Xcode’s project PRODUCT_BUNDLE_IDENTIFIER” step to change it to the enterprise bundle id. With this update it cannot find the Xcode managed provisioning profile as the profile has been managed by Bitrise. The fix was to revert back to 0.9.6.


Ensure Provisioning Profiles on Developer Portal
distribution_types: [“enterprise”]
checking xcode managed enterprise profile for target: RTV ( with 2 services on developer portal

failed to find Xcode managed provisioning profile for bundle id:

I’ll try generating it again today and see if it resolves it. Is this a new requirement with this version? It has been building fine for as long as I remember but as soon as we switched to v1.0 it broke. That would be an odd coincidence.

That fixed it, thanks!

1 Like

Exporting via xcode then running a rebuild has fixed it. Thanks! I guess by chance the profile must have expired at the exact same time as you releasing the update.

1 Like

Hi, sorry for the inconveniences!
Could you please write us a message on on-site-chat? I would need to have a look on your .xcodeproj file to debug the issue.

@MattCheetham, thanks for your debugging ad for sharing your experiences.

Before 1.0.0 the step does not cared if the project uses Xcode managed signing or not.
It picked the target bundle ids which needs to be signed and ensure both the app and the profile for the targets then it modified your project to use manual singing with the ensured codesigning resources.

This seemed to be fine, but in some cases if Xcode registers an App ID for your bundle id, it is not accessible on Developer Portal:

From 1.0.0 if the project uses Xcode manage signing it does not generates anything, since Xcode generates the codesigning files for you, the step just downloads them.

The problem is that by default the managed Profile is a development one, which is fine thought development. Xcode generates it for you and it is accessible on Developer Portal.

But the desired distribution Profile is only generated when you first time locally export an ipa file, with the desired distribution type and using xcode auto signing).

1 Like

I continue to have problems since 1.0. Projects that build fine using 0.9.7 fail:

:x: error: Provisioning profile “iOS Team Provisioning Profile: xxx” doesn’t include signing certificate “iPhone Developer: xxx”. (in target ‘xxx’)

Additional info: building an archive and exporting works fine in Xcode. But I still can’t get it to run using Bitrise. I tried to run “codesigndoc” again but the exported certificates seem to be the same and uploading them didn’t change anything.
It works by going back to 0.9.7

1 Like

Hi @matthias.buchetics,

please have a look on the auto-provision step’s log:

Provided an older version of iPhone Developer: XYZ certificate (serial: OLD_SERIAL expire: 2018-11-17 08:08:57 UTC),
please download the most recent version from the Apple Developer Portal (serial: LATEST_SERIAL expire: 2018-04-04 13:43:11 UTC) and use it on Bitrise!e

Your project uses xcode managed signing and xcode assigned the latest version of the certificate to your managed profile.

1 Like

I don‘t know what you mean exactly. The certificate that’s used (expires 2018-11-17) is the one that I use in Xcode (it’s automatically created), the others are from other developers in my team (using the same account) and I don’t have access to those. Also, why is the certificate that expires in November „old“ whereas the one from April is „latest“?
I used codesigndoc tool to export the certificates and uploaded those. Version 0.9.7 complained about old certs as well but worked.

This is the build that works (0.9.7): Bitrise - Mobile Continuous Integration and Delivery - iOS & Android Build Automation
And this one fails (1.0): Bitrise - Mobile Continuous Integration and Delivery - iOS & Android Build Automation

I don’t know why it complains about an older version as the certificate which expires on Sept 6th, 2018 is the newest one.

Provided an older version of iPhone Distribution: Our Company (xxx) certificate (serial: SERIAL_NR expire: 2018-09-06 13:02:24 UTC),
please download the most recent version from the Apple Developer Portal (serial: SERIAL_NR expire: 2018-08-23 09:54:57 UTC) and use it on Bitrise!

Hi @matthias.buchetics,
that is true, the step incorrectly printed this message, this will be also fixed in the new version.

Do you have any idea how to fix my problems or should I wait for the next version and stay on 0.9.7 until then?

We are OK for now. The solution is to ensure it is always using the enterprise bundle identifier, and signing identity when “automatically manage signing” is checked.

Hi, we released a new version of the step, please have a look on it and let us know how does it work for you: iOS Auto Provision v1.0.1

1 Like

Version 1.0.1 fixed all my issues! Thank you for the quick response.

1 Like

Glad to hear and thanks for reporting @matthias.buchetics! :slight_smile:

@viktorbenei unfortunately another issue popped up, that I described here: iOS Auto Provision v1.0.1
Please take a look.

Looking into it, will continue/reply there :wink: