Git clone is not working: Fatal: not a git repository (or any parent up to mount point /)

Bitrise Build Issue Report template

Description of the issue

Bitrise was building my github repo fine until recently, or say today. The build fails at git-clone and I got error “Repository not found” and “fatal: could not read from remote repository”. The exit status is 128.

I tried to rebuild a build job, which was successful before. It also failed with same error.

I tried to init, add, fetch, and checkout in terminal on my mac and they all worked fine.


Stack and machine type
Android & Docker, on Ubuntu 20.04

Which build Step causes the issue and which version of the step?
id: git-clone
| version: 6.2.3/7.x

Build log

Please copy paste the build’s URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - Contact us ), with a link to the related Discuss issue.

Here are the messages I got in Bitrise bulid log.

Start installing (git-lfs) with apt-get

  • [OK] Step dependency (git-lfs) installed, available.
  • RepositoryURL:
  • CloneIntoDir: /bitrise/src
  • Commit: a63aabe0df72fcab8ce5b993ea3e1b883d37XX
  • Tag:
  • Branch: development
  • PRDestBranch:
  • PRID: 0
  • PRSourceRepositoryURL:
  • PRMergeBranch:
  • PRHeadBranch:
  • ResetRepository: false
  • CloneDepth: 0
  • FetchTags: false
  • SubmoduleUpdateDepth: 0
  • ShouldMergePR: true
  • SparseDirectories:
  • BuildURL: Bitrise - Mobile Continuous Integration and Delivery - iOS & Android Build Automation
  • BuildAPIToken: [REDACTED]
  • UpdateSubmodules: true
  • ManualMerge: true
    $ git “remote” “-v” &> out
    Error: checking if origin is present failed: fatal: not a git repository (or any parent up to mount point /)
    Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
    | |
    | x | Git Clone Repository (exit code: 1) | 3.79 sec |

Yesterday i had no issues, and the build went ok, today seems that is not working correctly.
any way to fix this?

We would need to look into this issue for you deeper.

Can you open a support ticket here please: