Flutter repository access error

#1

Bitrise Build Issue Report template

Description of the issue

There was an error in the Fastlane step when making the flutter pub get from the Flutter module in the Android application. He says he didn’t find the repository or that the credentials are wrong. The stranger who steps before manages to clone the project.

Environment:

Where did the issue happen?

It occurs when we use Bitrise to generate a version of the master for Google Play

Which build Step causes the issue and which version of the step?

Fastlane v2.7.1

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : Every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : After changing the authentication user

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

I followed all the steps and it worked correctly.

Build log

0 Likes

#2

Hello everyone.

Talking to people here and breaking a lot of head we managed to find the the heart of the matter.

In the Bitrise tutorials he talks about configuring the SHH generated by him in the “Deploy key” in all repositories if he uses submodules. In my case I use Flutter as a submodule on Android.

I am using Github private and when doing the procedure it presents the message when configuring in the Flutter repository, “key is already being used”. The error occurs because I am using the same key in the Android repository and Flutter. This is even something that Bitrise offers to create SSH automatically in the repository’s “Deploy key”.

The solution I got was to configure the public SSH generated by Bitrise in the settings of my Github user who has access to the repositories and remove the “Deploy key” from the Android repository.

This implies that Github does not accept to use the same public key in several repositories.

I hope this helps people who are having the same or similar problem.

0 Likes

#3

Thank you @OsmarFilbido for the solution

Chaitanya

1 Like