Git clone from self hosted gitlab fails with access problems

Bitrise Build Issue Report template

Description of the issue

I am having issues cloning project on
while creating the app everything goes fine, bitrise accepts the ssh key and accesses the repository and automatically detects that the project is of flutter.
But after the setup during the first build git clone fails with

Warning: Permanently added '' (ED25519) to the list of known hosts. Permission denied (public[REDACTED]).
fatal: Could not read from remote repository.
Please make sure you have the correct access rights
and the repository exists.

Account access on gitlab is maintainer and on bitrise is admin

Also i have to mention that I am using the same self hosted gitlab account in another bitrise account which works perfetly fine.


Where did the issue happen?

Xcode 14.2.x macOs13.2 Ventura

Which build Step causes the issue and which version of the step?

Git Clone v8.x.x(same with previous versions btw)


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : everytime
  • Does upgrading the build Step to the latest version help? :NO
  • When did the issue start? : 2023/3/8

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what will get when it does a git clone in the clean environment! If possible please note which sections you tried.

I tried building locally but because of CLI it skips the clone step

1 Like

This was resolved after stack was changed to android, docker, ubuntu.
The reason is still unclear but maybe the ssh file path was a problem with xcode stack??

A little clarification,
I was write in a way to change the stack but changing it to android, docker, ubuntu wasn’t

so the reason for clone failing was the type of the key.
I had tried RSA and ECSDA keys but apprently MacOS Ventura needs ed25519 or enable RSA/SHA keys

the following was something I found in bitrise docs but didn’t work as intended. Maybe some tuning is required

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.