Flutter can not build with Android appbundle

#1

Bitrise Build Issue Report template

Description of the issue

I can’t build flutter app android with appbundle . Currently after this command flutter "build" "appbundle" "--flavor" "prod" "--release" log show step stuck at Resolving dependencies... and auto abort by bitrise timeout. This command worked with me before. But build apk release still work well. ( I enable support access already )

Environment:

Flutter Android build app bundle

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? (Plus any other information you can share)

Which build Step causes the issue and which version of the step?

Flutter build android appbundle 0.12.0

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : Every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : Yesterday

Local reproduction

It work well with local build with Bitrise CLI

Local reproduction: Linux / Android (docker based) stack builds

No it can’t be reproduced in locally.

Build log

https://app.bitrise.io/build/c88e270c877ea6db#?tab=log

0 Likes

#2

Hi there @MinhMark :wave:

Thanks for contacting us!
Currently Flutter seems to have an issue with appbundles, but reverting back to a previous version (Flutter v1.7.8+hotfix.4) will fix the issue :slight_smile:

Hopefully they will deploy a fix for the current version soon :slight_smile:

0 Likes

#3

Still not working… I need the last Flutter version to build it. It works locally, so It seems to be a problem with Bitrise

0 Likes

#4

@DavidFD could you pase the related build URL here? :slight_smile:

0 Likes

#6

this one: https://app.bitrise.io/build/529f158707773a84#?tab=log

0 Likes

#7

Hi @DavidFD!

As we understand through our chat conversations, the issue was resolved with using the v1.9.1+hotfix.2-stable version of flutter.

Feel free to correct us if we’re wrong and if this needs any more assistance!

0 Likes

#8

Unfortunately I still ran into the same problem :confused:

I have to use Flutter 1.9.1+hotfix.6 and everytime I try to build my android application within a workflow step (flutter “build” “appbundle” “–release”), the build get a timout trying to resolve the dependencies after initializing gradle.

Everything works fine on my local machine.

0 Likes

#9

I can’t build flutter app with android appbundle too.
Reverting it back to v1.7.8+hotfix.4 - is not an option for me.

So, the problem still exists in Flutter 1.9.1+hotfix.6

0 Likes