Failed to boot emulator device within 300 seconds

Bitrise Build Issue Report template

Description of the issue

We are seeing builds fail because the Android emulator isn’t booting.


Where did the issue happen?

If on which stack? If not on on what operating system? (Plus any other information you can share)

This happened on BitRise; using the Android stack.

Which build Step causes the issue and which version of the step?

Start emulator
Failed to boot emulator device within 300 seconds.
| |
| x | avd-manager@0.9.2 (exit code: 1) | 493 sec |
| Issue tracker: |
| Source: |


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO (maybe it does sometimes; it happens sporadically)
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : sporadically
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : over the last few weeks

Local reproduction

Can it be reproduced on your own Mac/PC by following our [local debug guide])? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what will get when it does a git clone in the clean environment! If possible please note which sections you tried.

It worked fine locally, but then the issue is sporadic so it’s difficult to draw conclusions from this.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ? If no, can it be reproduced with Docker (using the same docker images / environment we use on Related guide: .

It worked fine locally, but then the issue is sporadic so it’s difficult to draw conclusions from this.

Build log

Please copy paste the build’s URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - ), with a link to the related Discuss issue.


Hi @craig !

Sorry for the delayed answer.
The Tooling Team is investigating the issue.

Could you please enable the “Bitrise Support User” for your app by:

  • Open your app.
  • Select the Settings tab.

During the investigation, if you think you can try the other options:

  1. “[BETA] Virtual Device Testing for Android” step.
    You can read more about it here:

  2. Or the “App Center upload and schedule tests”
    You can read more about it here:

Thanks - i have now enabled Bitrise Support User.

I will attempt to try out the VDT approach when I can, but I’m a bit pressed for time right now. I’ll post back if I can wrangle some time for it.

Hi @craig,
Just wanted to get back to you on this issue. We are investigating what could cause the hanging. Currently we see that the following would solve the issue in most cases:

  • Setting Verbose Mode in the Customize section of the AVD Manager step to false
  • Downgrading the AVD Manager step to version 0.9.1

Let me know if this solves your issue!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.