AVD Manager fail on Start emulator

Hi,

we are using AVD Manager and its failed on Start emulator with below error message.

Failed to boot emulator device within 300 seconds.

I tried with hw.gpu.mode=host value also but the same error message.

Please advice on this.

Step (0) to accept all the licenses:
Script content:

#!/bin/bash
# fail if any commands fails
set -e

# debug log
set -x

# For newer Android SDK:
sdkmanager “extras;android;m2repository”
sdkmanager “extras;google;m2repository”

yes | sdkmanager --licenses
±-----------------------------------------------------------------------------+

| (1) avd-manager |
±-----------------------------------------------------------------------------+
| id: avd-manager |
| version: 0.9.2 |
| collection: https://github.com/bitrise-io/bitrise-steplib.git |
| toolkit: go |
| time: 2018-05-09T22:36:23-07:00 |
±-----------------------------------------------------------------------------+
| |
INFO[22:36:23] * [OK] Step dependency (go) installed, available.
Configs:

Version: 27
Resolution: 240x426
Density: 120
Orientation: portrait
Tag: google_apis
ABI: x86
Profile: Nexus 5X
ID: Google_Nexus_5_Emulator
CustomCommandFlags: -no-window -no-audio -debug-init -no-boot-anim
Overwrite: true
CustomConfig:
disk.dataPartition.size=1024M
hw.camera.back=emulated
hw.camera.front=emulated
hw.keyboard=yes
hw.gpu.enabled=true
hw.gpu.mode=swiftshader
hw.ramSize=1536
runtime.network.latency=none
runtime.network.speed=full
showDeviceFrame=no
skin.dynamic=yes
skin.path=_no_skin
skin.path.backup=_no_skin
vm.heapSize=384

Ensure sdk packages: [tools platform-tools system-images;android-27;google_apis;x86]
Done

Create AVD
Done

Start emulator
**Failed to boot emulator device within 300 seconds.**

| |
±–±--------------------------------------------------------------±---------+
| x | avd-manager (exit code: 1) | 423 sec |
±–±--------------------------------------------------------------±---------+
| Issue tracker: https://github.com/bitrise-steplib/steps-avd-manager/issues |
| Source: https://github.com/bitrise-steplib/steps-avd-manager |
±–±--------------------------------------------------------------±---------+
1 Like

Hi @vermas,
sorry for the inconveniences! Which stack do you use on bitrise.io?

I tried the step on Android & Docker on Ubuntu 16.04 stack with the following configs:

- Version: 27
- Resolution: 240x426
- Density: 120
- Orientation: portrait
- Tag: google_apis
- ABI: x86
- Profile: Nexus 5X
- ID: emulator
- CustomCommandFlags: -no-window -no-audio -debug-init
- Overwrite: true
- CustomConfig:
disk.dataPartition.size=1024M
hw.camera.back=emulated
hw.camera.front=emulated
hw.keyboard=yes
hw.gpu.enabled=true
hw.gpu.mode=swiftshader
hw.ramSize=1536
runtime.network.latency=none
runtime.network.speed=full
showDeviceFrame=no
skin.dynamic=yes
skin.path=_no_skin
skin.path.backup=_no_skin
vm.heapSize=384

and it boots fine.

2 Likes

Hi,

Sorry for late reply.
We are using below stack:

Hybrid (Xamarin, Ionic, …) on macOS, includes Visual Stuido for Mac, Stable channel

Just now i tried and again its failed.
Please let me know if you need any further information.

Thanks

The Hybrid stacks don’t support the x86 emulators, only the ARM ones.

If you want to use the x86 emulators please use the Android/Linux stack.

1 Like

Hi Viktorbenei,

Thanks for reply. I used the same and now my scripts stuck on gradle-runner with below error message.

±-----------------------------------------------------------------------------+
| bitrise summary |
±–±--------------------------------------------------------------±---------+
| | title | time (s) |
±–±--------------------------------------------------------------±---------+
| ✓ | script | 21 sec |
±–±--------------------------------------------------------------±---------+
| ✓ | avd-manager | 154 sec |
±–±--------------------------------------------------------------±---------+
| ✓ | activate-ssh-key | 5.42 sec |
±–±--------------------------------------------------------------±---------+
| ✓ | git-clone | 19 sec |
±–±--------------------------------------------------------------±---------+
| ✓ | npm | 45 sec |
±–±--------------------------------------------------------------±---------+
| ✓ | script@1.1.5 | 99 sec |
±–±--------------------------------------------------------------±---------+
| ✓ | file-downloader | 2.43 sec |
±–±--------------------------------------------------------------±---------+
| x | gradle-runner (exit code: 1) | 72 sec |
±–±--------------------------------------------------------------±---------+
| Issue tracker: https://github.com/bitrise-io/steps-gradle-runner/issues |
| Source: https://github.com/bitrise-io/steps-gradle-runner |
±–±--------------------------------------------------------------±---------+

±-----------------------------------------------------------------------------+

| (7) gradle-runner |
±-----------------------------------------------------------------------------+
| id: gradle-runner |
| version: 1.8.3 |
| collection: https://github.com/bitrise-io/bitrise-steplib.git |
| toolkit: go |
| time: 2018-06-01T19:38:30Z |
±-----------------------------------------------------------------------------+
| |
INFO[19:38:30] Start installing (golang) with apt-get
INFO[19:38:30] * [OK] Step dependency (go) installed, available.
Configs:

Thanks
Sunit

Hi @vermas ,
please create a new topic, for the new issue.

By the way it seems you have a configuration issue, which can have several sources: https://stackoverflow.com/questions/32153544/errorcause-buildtoolsversion-is-not-specified

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.