ETIMEDOUT on 'yarn install' only in Android-Ubuntu Stacks

#1

Hello,
This issue is started happening today on our Android builds only ( it works perfectly on iOS builds)

I think maybe yarn have to be updated in those Stacks to support the latest version (1.16.0) that retries when having Etimedout

Update:
i forced yarn to the latest version , but i still have the same problem

0 Likes

#2

Hi @mlagrouh! Sorry to hear about the issue and thanks for the report. Can you please include a build URL?

0 Likes

#3

Sure @bitce, here it is: https://app.bitrise.io/build/17b1f4b1ac7874de

0 Likes

#4

Thanks! Is this issue persistent if you try rebuilding? I can not recreate this at all

0 Likes

#5

Yes , all our builds are failing :confused:

0 Likes

#6

Can you allow us Support Access ( https://devcenter.bitrise.io/troubleshooting/enabling-bitrise-support-user/ ) so that we can take a more in-depth look?

0 Likes

#7

it is done !

0 Likes

#8

One thing, is that we are using a private registry to get packages from , but it is weird that they are well downloaded in Mac Stacks , and not in Android/Linux Stacks , maybe there is a firewall that prevents this

0 Likes

#9

Hi @bitce, any update on this issue ? , thanks !

0 Likes

#10

Hy, sorry for the late reply, can you try out this? https://github.com/yarnpkg/yarn/issues/4877#issuecomment-342794413
or try installing the packaged with npm maybe?

0 Likes

#11

Hi @fehersanyi-bitrise no problems.

I want to try npm config set https-proxy but I don’t know which proxy I should use. Any idea ?

I tried to run ping proxy to get it, however ping command doesn’t seem to be installed on the docker image.

Thanks

0 Likes

#12

Hy, sorry for the late reply,

I’m not really at home in this topic, but you can install ping like this: apt-get install -y iputils-ping

0 Likes