Error in fastlane/gym Preprocessing Info.plist

Bitrise Build Issue Report template

Description of the issue

Build works perfectly on local machine. On bitrise.io it fails consistently

Environment:

Bitrise.io, Xcode 8.3.x on Sierra

Fails on fastlane step, v2.3.9

▸ Check Dependencies
▸ Preprocessing DockGenius/Info.plist
** ARCHIVE FAILED **

The following build commands failed:
Preprocess /Users/vagrant/Library/Developer/Xcode/DerivedData/DockGenius-bnynkyrxllperxbzyzfnfgfzshjk/Build/Intermediates/ArchiveIntermediates/DockGenius/IntermediateBuildFilesPath/DockGenius.build/Debug-iphoneos/DockGenius.build/Preprocessed-Info.plist DockGenius/Info.plist
(1 failure)

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) :NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. :NO
  • If you have multiple different build configurations (workflows), does the issue affect all/more than one? : N/A
  • If it’s an issue which happens sporadically, what’s the frequency? (e.g. Once a day ; about x% of the builds) : Always
  • Does upgrading the build Step to the latest version help? :NO
  • When did the issue start? : First push of the project. I have tried in the past, same project and same error until you disabled the project

Other stacks

Can it be reproduced by running the build locally with our CLI ( https://www.bitrise.io/cli ), after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )?

Build log

Hi @jcmendez,

Can you please follow this guide How to debug your build locally / "It works on my Mac/PC but not on bitrise.io" and let us know how it goes?

Note: starting with a clean git clone into a new directory (e.g. into /tmp) is crucial, to test the state of the code bitrise.io gets when it does a git clone (e.g. no .gitignored files present).

Testing with a full clean git clone and the bitrise CLI works without issue. It’s about the filesystem that you have on your end being readonly or with the wrong permissions and when the app tries to create two files dynamically that contain the git hashes (they are not in the repo, and are specifically not checked in), the build fails

I already enabled the support permission checkbox on the project so you can take a look yourself

What’s the build URL? Can you send it to us through the onsite chat?

It’s a standard macOS install, absolutely no customization in the filesystem. We just install macOS in the VM, install Xcode on it, and then we run this: https://github.com/bitrise-io/osx-box-bootstrap

That’s all, these mac stacks are all “vanilla” macOS installs with Xcode and a couple of preinstalled tools.

Please copy paste the build/app bitrise.io URL here or send through the onsite chat, as we have too many projects on the support account to be able to tell which one’s yours.

Did you check the raw fastlane logs @jcmendez? It’s attached to the build in the Apps & Artifacts section.

From the raw log (from the gym_DockGenius-DockGenius.log log file):

<built-in>:1:10: fatal error: '/Users/vagrant/git/DockGenius/git_version.h' file not found
#include "/Users/vagrant/git/DockGenius/git_version.h"

Simply something references that file, but that does not exist, it seems.

(Note: /Users/vagrant/git is the directory where the repository is cloned/checked out)