Download link not showing on public install page in iOS 13.1.3

Hello. I am trying to add our app to a new test device that is running iOS 13.1.3 and when I get to the public installation page I get the message “Open this page in Safari (in non incognito mode) on your iOS device to install the app.” I am on the iOS device, in Safari, in non incognito mode. If I load the page in an iOS device that has an older version (12.4) the install button shows just fine. Appreciate any thoughts; this is a test device that is being shared with a client and is time sensitive.

Hi @ConnectSx, :wave:

May I ask if you are experiencing this on an iPad?
Due to a change in the user agent string for iPadOS, the iPadOS version of Safari currently requests the desktop versions of websites. This breaks the functionality of our public install page. As mentioned in this thread, the best workaround is currently to request the mobile version of the website in Safari’s settings.
Our team is currently trying to find a way around this, but until then please use the workaround mentioned. Thank you for your kind understanding! :blush:


Thanks @cskata. That worked for me. :grinning:

Glad to hear that, @ConnectSx! :smiley: :tada: Please let us know if you have any further questions.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.