Deploy to iTunes Connect Error

I get an error on “Your Apple ID account is attached to other iTunes providers. You will need to specify which provider you intend to submit content to by using the -itc_provider command. Please contact us if you have questions or need help. (1627)”.
I don’t understand at all :frowning:

I haven’t sent any build to itunes connect via bitrise yet, but by the looks of the error I’d say that your apple developper account is linked to multiple Itunes providers (multiple companies I guess) and that you should precise on which company you wished to send the build via the -itc_provider (I guess it’s a parameter your can specify when sending the build)

1 Like

But I’m giving the Team ID in the parameters for this part of the workflow. Also I have no idea where to write the -itc_provider and what to write there.

What’s the step you used in your workflow? (I think there are two steps to send a build on itunesConnect right now)

I can take a look, I haven’t tried to send a build to itunesConnect yet because I have another issue that doesn’t permit me to do it.

1 Like

This stackoverflow thread might also help:

It seems this might be caused by a pending agreement e.g. on which you have to accept.

Thank you for trying to help, but this is a new account and Application Loader is working perfectly. It is only through Bitrise that is doesn’t work.

There is only one step now for iTunes Connect - the title is “Deploy to iTunes Connect”. The other one (Deploy to iTunes Connect / TestFlight (with Shenzhen)), which works perfectly by the way, is now obsolete…

Ok, I just took a look at the step source code, and it uses fastlane, maybe the API changed and the step isn’t updated yet.

What you can also try, is to set the Team name instead of the team id, as i see you can set both but only one will be taken into account. It’s worth a shot I guess.

If it still doesn’t work, I encourage you to write an issue on the step github :

Maybe they’ll be able to help you more than us :slight_smile:

1 Like

Will try it, thanks

1 Like

Let us know how it goes @Iditb! :wink:

Hi @Iditb,

it seems you need to specify a fastlane deliver command’s flag: --itc_provider .
This flag is not wired in as a step input for the Deploy to iTunes Connect step,
but the step has an input: Additional options for deliver call, this input allows you to specify additional flag for the deliver call.

To get your itc provider pls run:\ \
  -m provider \
  -u 'USERNAME' \
  -p 'PASSWORD' \
  -account_type itunes_connect \
  -v off

once you get your provider specify the Additional options for deliver call: --itc_provider YOUR_PROVIDER input of the Deploy to iTunes Connect step.

It works, thanks a lot. I needed to write --itc_provider TEAM_ID


Thanks for reporting @Iditb! :slight_smile:

Ohh and thanks for the tips @jvossen! :wink: