Could not configure Apple Service authentication: no credentials provided

step
deploy
ios
#1

Bitrise Build Issue Report template

Description of the issue

Credentials are not working on the step ‘Deploy to iTunes Connect - Application Loader’.
This was working on previous version (0.X.X), I have correct apple id and password set up. But I get following error:

Could not configure Apple Service authentication: no credentials provided

I’m using apple_id connection (so no API), and I double checked that Apple ID and Password are correct.
I’m guessing that I have something wrong on my settings, since this never worked with version 1.X. I haven’t found help anywhere, hence this topic.

Thanks for the help

Environment:

Where did the issue happen?

Xcode 12.5.x, on macOS 11.2 (Big Sur)

Which build Step causes the issue and which version of the step?

deploy-to-itunesconnect-application-loader@1.1

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? : NO
  • Does the issue happen sporadically, or every time? : Every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : When I upgraded from version 0.x to 1.x (latest)

Local reproduction

_Can it be reproduced on your own Mac/PC?
I get the same result locally with Bitrise CLI. I put the credentials in .bitrise.secrets.yml file.

Build log

0 Likes

#2

Having the same issue, authentication with apple_id/password works fine in version 0.X but is not working in version 1.X ( Could not configure Apple Service authentication: no credentials provided).

0 Likes

#3

Hi @JavRok and @pedro.leal! This error message suggest you haven’t selected the Apple account on the Team tab of your app for your project to be using. If you select ‘apple_id’ as your method, step inputs other than the App Specific Password are ignored. If you leave it on automatic, they’re used as a fallback, so switching that setting in itself might solve this.

This is just a guess however, please include a build URL or logfiles if you’d like us to take a look at these issues.

1 Like