Cordova App Build Fail: framework not found FileProvider for architecture i386

Bitrise Build Issue Report template

Description of the issue

Pasted the code block with the error below. I get this issue when I try to run my builds. I tried adding a provisioning profile and certificate to our build to see if that would fix the issue and it did not. It seems like this ‘framework’ is just missing.

Ld /Users/vagrant/Library/Developer/Xcode/DerivedData/Medici-aizfvindntoaoqhenbpuwtdrjvef/Build/Intermediates/ normal i386
    cd /Users/vagrant/git/patient/cordova/platforms/ios
    export PATH="/Applications/"
    /Applications/ -arch i386 -isysroot /Applications/ -L/Users/vagrant/git/patient/cordova/platforms/ios/build/emulator -L/Users/vagrant/git/patient/cordova/platforms/ios/Medici/Plugins/cordova-plugin-iosrtc -L/Users/vagrant/git/patient/cordova/platforms/ios/Medici/Plugins/pushwoosh-cordova-plugin -F/Users/vagrant/git/patient/cordova/platforms/ios/build/emulator -FMedici/Plugins/com.adjust.sdk -FMedici/Plugins/cordova-fabric-plugin -FMedici/Plugins/cordova-plugin-facebook4 -FMedici/Plugins/cordova-plugin-googleplus -filelist /Users/vagrant/Library/Developer/Xcode/DerivedData/Medici-aizfvindntoaoqhenbpuwtdrjvef/Build/Intermediates/ -Xlinker -rpath -Xlinker @executable_path/Frameworks -mios-simulator-version-min=9.0 -dead_strip -Xlinker -object_path_lto -Xlinker /Users/vagrant/Library/Developer/Xcode/DerivedData/Medici-aizfvindntoaoqhenbpuwtdrjvef/Build/Intermediates/ -Xlinker -objc_abi_version -Xlinker 2 -fobjc-arc -fobjc-link-runtime -L/Applications/ -Xlinker -add_ast_path -Xlinker /Users/vagrant/Library/Developer/Xcode/DerivedData/Medici-aizfvindntoaoqhenbpuwtdrjvef/Build/Intermediates/ -ObjC -Xlinker -sectcreate -Xlinker __TEXT -Xlinker __entitlements -Xlinker /Users/vagrant/Library/Developer/Xcode/DerivedData/Medici-aizfvindntoaoqhenbpuwtdrjvef/Build/Intermediates/ /Users/vagrant/git/patient/cordova/platforms/ios/build/emulator/libCordova.a -framework AdjustSdk -weak_framework AdSupport -weak_framework iAd -lz -lc++ -framework SystemConfiguration -weak_framework Security -framework Fabric -framework Crashlytics -weak_framework ImageIO -framework CoreLocation -framework AVFoundation -weak_framework AddressBook -weak_framework AddressBookUI -lz -framework CoreMotion -framework Bolts -framework FBSDKCoreKit -framework FBSDKLoginKit -framework FBSDKShareKit -framework GoogleAppUtilities -framework GoogleAuthUtilities -framework GoogleNetworkingUtilities -framework GoogleSignIn -framework GoogleSymbolUtilities -framework GoogleUtilities -weak_framework CoreText -weak_framework SafariServices -lWebRTC-LATEST-Universal-Release -framework CoreMedia -framework GLKit -framework OpenGLES -framework CoreVideo -framework CoreAudio -framework QuartzCore -framework AudioToolbox -lstdc++ -lsqlite3.0 -framework VideoToolbox -framework Foundation -framework CoreTelephony -weak_framework WebKit -weak_framework Social -weak_framework MessageUI -framework CoreBluetooth -framework Photos -framework EventKit -framework Contacts -framework UserNotifications -framework CallKit /Users/vagrant/git/patient/cordova/platforms/ios/Medici/Plugins/pushwoosh-cordova-plugin/Pushwoosh -framework Storekit -Xlinker -dependency_info -Xlinker /Users/vagrant/Library/Developer/Xcode/DerivedData/Medici-aizfvindntoaoqhenbpuwtdrjvef/Build/Intermediates/ -o /Users/vagrant/Library/Developer/Xcode/DerivedData/Medici-aizfvindntoaoqhenbpuwtdrjvef/Build/Intermediates/
ld: framework not found FileProvider for architecture i386
clang: error: linker command failed with exit code 1 (use -v to see invocation)


This issue happened while trying to build our project using bitrise

If on which stack? If not on on what operating system? (Plus any other information you can share)

The stack is Hybrid stack, with both Android tools and Xcode 8. The step that the issue occurs in: cordova-archive@1.0.1.

E.g.: Git Clone v3.6.0


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : YES/NO

  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : YES/NO

  • Does the issue happen sporadically, or every time? :
    Every time.

  • Does upgrading the build Step to the latest version help? : YES/NO
    Not sure where to edit this.

  • When did the issue start? :

    Issue started when I tried to get bitrise working. Haven’t had a successful build yet.

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( Bitrise CLI )? If no, can it be reproduced with Docker (using the same docker images / environment we use on Related guide: Redirecting… .

Build log

Please copy paste the build’s URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - Contact us ), with a link to the related Discuss issue.

Turns out this was a versioning issue. We were running cordova 7.0.1 locally and ^6.5.0 in the project. We needed to run the 7.0.1 version in our stack, and add that we wanted to run ^6.5.0 in the cordova config settings.

1 Like

Glad to hear you managed to solve the issue @joeystein!

Sorry for the delay and thanks for sharing both the issue & the solution, I’m sure this will help others too! :wink: