Code signing doesn't work after upgrading to Xcode 13.0 stack from Xcode 12.5

Bitrise Build Issue Report template

Description of the issue

The build worked fine on Xcode 12.5 stack, then I decided to upgrade to Xcode 13 and start receiving code signing error:

error: No profiles for ‘…’ were found: Xcode couldn’t find any iOS App Development provisioning profiles matching ‘…’. Automatic signing is disabled and unable to generate a profile.

Switching back to Xcode 12.5 again compiles fine, which means signing certificates and provisioning profiles are installed correctly.


The issue is happening on Xcode 13.0 stack on mac OS 11.4. Xcode 12.5 stack worked fine.

Which build Step causes the issue and which version of the step?

Changing the stack to Xcode 13.0 from Xcode 12.5, using the latest (3.3.2) Xcode Archive & Export for iOS step.


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : the first time I’ve changed stack to Xcode 13.0 (12th Aug 2021)

Build log

Please copy paste the build’s URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - Contact us ), with a link to the related Discuss issue.
Bitrise - Mobile Continuous Integration and Delivery - iOS & Android Build Automation

Hello @reven86 :wave:

Can you please enable Support Access on the Settings tab of the app ( Enabling the Bitrise Support user for your app | Bitrise DevCenter ) so that we can take a more in-depth look? :slight_smile:

Thanks! I’ve enabled Support Access and checked the issue, just in case, it is still present. Project wot-armor-inspector.

Hello Andrew,

Thanks for the information!

According to the logs, the archive failed before even the build. This mostly happens when a cocoapod/dependency is invalid and or the project still uses legacy build system ( which got removed from Xcode 13 ).

Also, Xcode 13 no longer supports (iPhone Developer: *) certificates, only Apple Development: *, and they seem to be in used here. Our Steps still may use iPhone Developer if found, so the solution is to only include Apple Development cert in the build.

Hope this helps!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.