Can't delete cache for a branch due to "not found," but builds on that branch will still use that cache


I have a branch that fails to build because it cached at a non-working state. When I try to delete the cache, it fails because it’s “not found.” However, each time I build that branch, it successfully download the cache that was “not found” earlier. I haven’t tried clearing all cache because it’s going to take over an hour getting my carthage dependencies built again.

This was not the first time I’ve run into this issue.

1 Like

Thanks for reporting @soulphalanx!

Can you please enable Support Access for the app on the Settings tab of the app, so that we can look into it, and copy paste the app’s URL? We’ll check it ASAP! :slight_smile:

Support Access enabled and the url is

You’re talking about the test-bench-build+bac.. one, right?

We’ll check this ASAP!

Yup. test-bench-build+backgroundtask

1 Like

Hi, we managed to reproduce the issue, it should be fixed shortly. I will inform you when the fix has been released. Thanks for reporting it!

The fix has been released, you should be able to delete the build cache now. Thank again for reporting the issue, and happy building :slight_smile:

1 Like

Worked! Thank you!

1 Like

Glad to hear, and thanks for reporting @soulphalanx! :slight_smile: