Cache Pull failing, but previous Cache Push worked

carthage
build-cache
ios
#1

I’ve been using CachePush/Pull to cache the dependencies for my iOS build that uses Carthage. This has been working for quite a while without any issues, but today, with no changes on my side the cache pull step has stopped working, even though the previous build’s cache push worked fine.

The error it reports is:

2017/10/27 03:01:31 Cache pull…
2017/10/27 03:01:32 Failed to get download url, error: Build cache not found. Probably cache not initialised yet (first cache push initialises the cache), nothing to worry about :wink:
WARN[03:01:32] Step (cache-pull) failed, but was marked as skippable

Are there any known issues that might cause this?

1 Like

#2

It appears to be working again. Perhaps just a temporary glitch? I’ll keep an eye on it.

1 Like

#3

Without more info / context & log hard to say - if it’d happen again please let us know! Usually an issue like this is because something like e.g. your team mate deletes the related cache before the build could pull it. Or it might be that the cache item expired (http://devcenter.bitrise.io/caching/about-caching/ - Cache Expiring).

In any case, if you’d have any issues with the cache just let us know, with as many info as you can share and we’ll dig into it ASAP! :wink:

Happy Building!

0 Likes

#4

Same problem exist since last 10 days with no success…

±-----------------------------------------------------------------------------+

| (2) cache-pull@2.1.3 |
±-----------------------------------------------------------------------------+
| id: cache-pull |
| version: 2.1.3 |
| collection: https://github.com/bitrise-io/bitrise-steplib.git |
| toolkit: go |
| time: 2020-01-07T09:59:48Z |
±-----------------------------------------------------------------------------+
| |
Config:

  • CacheAPIURL: [REDACTED]
  • DebugMode: false
  • StackID: osx-xcode-11.2.x

Downloading remote cache archive
Failed to get cache download url: build cache not found: probably cache not initialised yet (first cache push initialises the cache), nothing to worry about :wink:

WARN[09:59:55] Step (cache-pull@2.1.3) failed, but was marked as skippable

| |
±–±--------------------------------------------------------------±---------+
| ! | cache-pull@2.1.3 (exit code: 1) | 9.19 sec |
±–±--------------------------------------------------------------±---------+
| Issue tracker: https://github.com/bitrise-steplib/steps-cache-pull/issues |
| Source: https://github.com/bitrise-steplib/steps-cache-pull.git |
±–±--------------------------------------------------------------±---------+

0 Likes

#5

Hi there @chetan.dobariya!

Could you please send us a related build URL and enable Support Access (https://devcenter.bitrise.io/troubleshooting/enabling-bitrise-support-user/), so that we may investigate a bit? :slight_smile:

0 Likes

#6

Sure, here you go.

build : 67baeb1790a091ca

0 Likes

#7

Hey there @chetan.dobariya, thanks for the build log! Could you also enable Support Access (https://devcenter.bitrise.io/troubleshooting/enabling-bitrise-support-user/)? :slight_smile:
I’d need to confirm a few things connected to your project in order to find out the root of the issue.

0 Likes

#8

@Roland-Bak it is enabled now :slight_smile:

0 Likes

#9

Hey there @chetan.dobariya!

I can see that you have since managed to build your cache up, but there could be a number of reasons why the cache was:

1: someone in your org deleted the cache at one time
2: cache is related to a specific branch, which expires/is auto-deleted after 7 days if there’s no new build on that branch in the meantime . This means that if you do builds on a specific branch every day** (more frequently than a week), **it’ll never expire/won’t get deleted automatically. If you don’t start a build on that specific branch for more than 7 days, then the related cache will be removed, and your next build will run like the first time, when there was no cache for that branch yet.

0 Likes

#10

Thanks @Roland-Bak ,

Good to know that bitrise automatically delete cached if build not happend in 7 days.

is that possible to modify this settings from user side?

0 Likes

#11

Currently there is no feature to configure this on the user side, but if you feel that is something critical, you can always create a feature request :wink:

0 Likes