Builds Failing on New Machine (Detox Test)

Bitrise Build Issue Report template

Description of the issue

Please describe the issue here
Two days ago we were on an elite machine, part of our trial period, and we ran builds that ran successfully. Yesterday our trial ended and we got onto the subscription plan using standard machines. For some reason all the tests that were passing the night before all of a sudden fail. It fails the first time I run detox test --configuration ios.sim.release however if I run it for the second time on the same machine it works.


Where did the issue happen?

If on which stack? If not on on what operating system? (Plus any other information you can share)

Xamarin, Visual Studio for Mac, Stable channel, on macOS

Which build Step causes the issue and which version of the step?

E.g.: Git Clone v3.6.0


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : Every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : Ever since we moved to the new machines (Standard machines)

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what will get when it does a git clone in the clean environment! If possible please note which sections you tried.
No, it cannot be reproduced locally.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( )? If no, can it be reproduced with Docker (using the same docker images / environment we use on Related guide: .

Build log

Please copy paste the build’s URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - ), with a link to the related Discuss issue.

this is the build that successful on the elite machine:
This is the same workflow that failed the following day on the standard machine
Even though towards the end it shows that tests are passing if you look at the first detox suite we run, it always gives us the error:
"1) “before all” hook: _callee:"
If you look at the logs and search for it you should be able to see that it failed when first running detox test

Hi @bhavik,

There’s absolutely no difference between Standard and Elite environments except the available resources. The exact same VM is booted, with the exact same preinstalled tools etc., it’s just that the Elite subscription/config gets 2x CPU and 2x RAM, that’s the only difference.

So, based on this I’d say your builds are actually resource intensive / constrained, and the solution would be to use the Elite stacks, or optimize your build to be able to run with the more limited Standard resources.

If you have any questions just let us know! :slight_smile: