Failed to export test results

Bitrise Build Issue Report template

Description of the issue

All builds fail, Im getting a “Failed to export test results” message.


Xcode 11.3.x, on macOS 10.14.6 (Mojave)

If on which stack? If not on on what operating system? (Plus any other information you can share)


E.g.: Git Clone v3.6.0


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? :
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : From the first time I tried to build

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( Bitrise CLI )? If no, can it be reproduced with Docker (using the same docker images / environment we use on Related guide: Redirecting… .

Build log

Hi @GJZwart,

Thank you for reaching out.

Happy to assist you further however before I can do that, please complete the remaining questions and provide links to your build as requested. This helps us debug your issue further.

Thanks and looking forward to hearing from you.

Kind regards,

I did link to the build as requested.

I copied the url of the log page, here it is again. or do wou need something else???

Hi @GJZwart,

I’m receiving here on my end. Can you copy the link that would look something like

If that’s what you’re been doing, please download and upload the log manually here. If you don’t wish for it to be public, send an email referencing this topic to letsconnect [at]


Yeah, the log file was in the format you wrote… Ill try again and paste it as code instead…

Did you read the log, @non-binary?

Hi @GJZwart,

I was on sick leave this past little while (bad flu!) so I’m very sorry for the delay in getting back to you. With that said, I am back on the saddle and I hope to check this out shortly. Either me or another person on our team will get back to you soon.


Hope it was not the Whuhan Flu :wink:
Welcome back! Hope you are doing better! :smiley:

1 Like


From your build log, it looks like you have a dependency that could not be resolved because the server SSH fingerprint failed to verify. It looks like access to is needed.

Please review the following for info on setting this up:

Good luck!

1 Like

This is way to hard. Not anywhere in the doc you linked to is there anything that helps me. I, and all the other developers in my company, have enough work with writing code for the apps we make. On top of this, we have to learn a complicated system that does god-knows-what, with no apparently upside to it? I have used over one month trying to set this thing up. And its a really tiny project. No, Im giving this up. We would probably have paid for using this if you provided at least ease of use. The learning curve for this is not worth the time. Sorry.

Thanks for nothing. Wasted over a month, no decent answers, just a complete waste of time.

1 Like

Hi @GJZwart!

I just wanted to reach out to say that we’re really sorry for mistreating your issue report. Due to changes around the team and the systems we use that’s what happened. In case you’re aware around to tackle this issue again, please consider reporting it to us directly (via the web form or to