Build takes more than 90 min and timesout, cannot change timeout value

Bitrise Build Issue Report template

Description of the issue

Please describe the issue here

I tried building an android app and used both the android build tool and also gradle runner, i have removed all the other steps such as unitTest and lint check steps, but the build time is still 90 minutes and more, and i get a timeout. Everytime i try a rebuild, the same thing happens. I am not sure if its because of some dependencies in the app build takes so much time or is it abi affecting it all? Also, i keep getting no heap space error, even though i have the env_variables set, and even set in the file too but it does not help at all. I have tried editing bitrise.yml file added timeout : 120 but it doesnot seem to be working either.


Where did the issue happen?

If on which stack? If not on on what operating system? (Plus any other information you can share)

Which build Step causes the issue and which version of the step?

Gradle runner: 1.9.3

E.g.: Git Clone v3.6.0


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : DOESN’T HELP
  • Does the issue happen sporadically, or every time? : EVERYTIME
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : 3rd April 2020

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( )? If no, can it be reproduced with Docker (using the same docker images / environment we use on Related guide: .

Build log

Please copy paste the build’s URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - ), with a link to the related Discuss issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.