Bitrise always running the previous version of build/version number and not picking up the latest version from the app.json.

#1

Bitrise Build Issue Report template

Description of the issue : Bitrise is always running the previous successful build number and not picking up the latest version from the app.json.

Please describe the issue here : Bitrise is always running the previous successful build number and not picking up the latest version from the app.json. So the builds are always failing sayins "ERROR ITMS-90189: “Redundant Binary Upload. You’ve already uploaded a build with build number”

Environment: iOS an Android

Where did the issue happen? everytime i run the new build

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? (Plus any other information you can share) Xcode 11.3

Which build Step causes the issue and which version of the step? step 10 , Turtle Build. Collected the failed build logs and noticed that this step is reading the version from the manifest that has the previous succesfull build number.

E.g.: Git Clone v3.6.0

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : Everytime
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : Recently when i ran the new version of build after updating the version in app.json file in code.

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ .

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - https://www.bitrise.io/contact ), with a link to the related Discuss issue.

0 Likes