Build number decresed by 1522

Bitrise Build Issue Report template

Description of the issue

Instead of incrementing the build number, Bitrise decreased it from 6898 to 5376

Please describe the issue here

My build numbers are too low, breaking my builds

Environment:

Where did the issue happen?

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? (Plus any other information you can share)

Which build Step causes the issue and which version of the step?

E.g.: Git Clone v3.6.0

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : YES/NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : YES/NO
  • Does the issue happen sporadically, or every time? :
  • Does upgrading the build Step to the latest version help? : YES/NO
  • When did the issue start? :

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( Bitrise CLI )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ .

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - Contact us ), with a link to the related Discuss issue.

4 Likes

I have the same issue but don’t know why & what to do…

Same issue here, but it’s decreased with 1419. New builds increment it as usual though.
Changing the build number for the next build through settings doesn’t work either by the way! So we’re stuck and cannot release our app for the time being…

Same issue with our project.

Decreased from 3818 to 2744. Changing the next build number also doesn’t fix.

This has been occurring since last Friday for us. Went down 5 times by large numbers skip.

Sorry for not updating sooner - we released a related fix, should not happen again.

Please let me know if you’d still see the issue!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.