Android Unit test has freezing on bitrise

Hello to everyone!
I’m trying to build an android project on bitrise, but the workflow has freezing on Unit Test step.
I’ve tried to connect with remote machine via ssh to check what happening wrong, and i saw which specific unit test has blocking with this error:

java.lang.Thread.State: WAITING (parking)
	at sun.misc.Unsafe.park(Native Method)
	- parking to wait for <0x00000000e0060558> (a java.util.concurrent.CountDownLatch$Sync).

The unit test that has blocking use rxSingle (to execute a coroutine and return Single object) ad blockingGet (in order to execute a method synchronussly) from RxJava library.

Now, i tried to reproduce this issue on my local machine (mac OS) with bitrise client first, and docker container later, but i can’t reproduce the problem (all my unit test pass).

Someone can help me? Thanks

Hello @FabioGraciotti :wave:

The first step we recommend when a build works locally but fails on our server (this includes tests tests) is to follow the steps found at:

It is crucial that you try and do this in the /tmp folder (as described in the guide), as that will enable you to run the build in a clean environment.
This should help you pinpoint the source of the issue :slight_smile: