Xcode problem with database locked when running tests on 2 targets consecutively


I tried switching my stack to the latest Xcode 14.1 version, but when I do so, I get an error on one of my workflow where I run tests on 2 targets consecutively.

here is the error : ❌ error: unable to attach DB: error: accessing build database "/Users/vagrant/Library/Developer/Xcode/DerivedData/myProject/Build/Intermediates.noindex/XCBuildData/build.db": database is locked Possibly there are two concurrent builds running in the same filesystem location

I’m running 2 different xcode test steps and thid happen in the second one.

I don’t know what I’m doing wrong and everything was fine with the Xcode 13.4.z stack :confused:

I hope someone will have some insight on that.

Thank you in advance for your help.

Have a great day.

This would need to be looked into further to say more.

You can open a support ticket here: https://support.bitrise.io/hc/en-us/requests/new

Shoot me the ticket number once opened and we can go from there.

here is the ticket id : #34099

thank you for your help

1 Like