XCode 9 Build Failing

Hi @dhavalcue,
could you please share your failed build log file with us?

Will this do?


Based on your log:

For ExportMethod input you specified: auto-detect, which means:

If you select `auto-detect` step will figure out proper export method
        based on provisioning profile embedded into generated xcodearchive.

based on your archive log, your archive was done with your development profile and assigned certificate, this specifies: development export method.

Then the step creates the possible code sign settings, like which installe profiles with which installed certificate can export your archive with the specified export options. you defined only development export method.

Our default development profile and certificate is installed in your builds, the profile is a wildcard development one. So it matches to your bundle id and also matches to the selected export method, so the step thinks its a valid code sign setup (currently we can not detect if notification is setup for the profile, thats why it is not fully matching code sign setup).

e[33;1mMultiple code singing groups founde[0m
e[33;1mUsing first groupe[0m

You should try to either specify more export options (like ExportTeamID) or disable our default certificate and profile in your certificate installer step. This way the only remaining and (truly) valid code sign setup will be yours and it should work.

1 Like

Thanks @godreikrisztian. That seemed to help a bit. However, I’m now seeing the Seg fault issue again.


@dhavalcue could you please set the xcode-archive step’s output tool input’s value to: xcodebuild? By default we use xcpretty log prettifier, but it hides your export issue.

Please run a new build and share its url with me.

@godreikrisztian: With xcodebuild: https://www.bitrise.io/api/build/a25b8cd04e8dd45c/logs.json?&download=log

Seems like you will need to disable compile bitcode in your step’s settings. This segmentation fault error is in xcode9’s changelog also.

1 Like

@dhavalcue, please set the Rebuild from bitcode input’s value to false.

Also please set the Deploy to Bitrise.io - Apps, Logs, Artifacts step’s Run if previous Step failed flag to true, we put debugging files, in your deploy dir in error cases (like: xcdistributionlogs).


@godreikrisztian, @tamaspapik: Thank you! Disabling bitcode compilation fixed this! :slight_smile:


Setting the team ID explicitly - fixes the issue, however i would prefer to disable the generation of the default Bitrise Provisioning profile.
Unfortunately i was not able to figure out a way to do it, so any help would be appreciated on this.

To disable them you simply need to clear the inputs containing the default URLs in the certificate installer step. After doing so, that part of your bitrise.yml should look like this:

    - certificate-and-profile-installer:
        - default_certificate_url: ""
        - default_certificate_passphrase: ""
        - default_provisioning_profile_url: ""

This works, thanks.
Just to clarify - the default inputs are under Debug settings of the step.