Website is unusable on Safari


#1

When using Bitrise on Safari, the website is broken when accessing the unlock editor, and, on mobile, yml editor, and env editor is completely unusable. It makes using Bitrise on Safari impossible.


#2

Hi, sorry for the inconvenience. Our developers will look into this issue. Could you provide screenshots of the issues you are facing? We’ve used the website on Safari before and had no issues that we are aware of.


#3

Sorry @erosdome, but if you are using Safari, I would love to have access to the same webpage that you are using! Because it is completely broken. Specially on mobile.

Bug 1:
When trying to access the env vars using Safari on iPhone, the website gets stuck, and I need to close the tab, or the app. So, it is IMPOSSIBLE to access this area of the project. Example: https://www.dropbox.com/s/fjod130p3qv6f2m/env_vars.mp4?dl=0

Bug 2:
Something that I reported MANY TIMES before: The scroll of the workflow configuration is also broken. When you scroll, the back scrolls, but the workflow doesn’t. Example: https://www.dropbox.com/s/97qheakknp09p8h/scroll.mp4?dl=0

Bug 3:
Using Safari, on Mac, the YML file editor is HORRIBLY slow, and broken. Here is an example where I just scroll through the file. See that the video is not loosing frames, and it is not edited. It is the editor that is really broken: https://www.dropbox.com/s/2lja2bsqsoc2sd0/safari_web.mp4?dl=0


#4

I haven’t manage to reproduce bug #1, although it sometimes takes quite a lot of time to load, isn’t that the case for you? Nevertheless, I created an issue report of it which you can track to see when it will be fixed: https://github.com/bitrise-io/bitrise-workflow-editor/issues/298

The bug #2 is something we’ve seen before, and released a fix for it, but it looks like it still needs some update. I reopened the card: https://github.com/bitrise-io/bitrise-workflow-editor/issues/141

I couldn’t reproduce bug #3 either, the YML editor runs smoothly for me on Safari on Mac. But I created an issue report of it: https://github.com/bitrise-io/bitrise-workflow-editor/issues/297


#5

Hi @FWIgor,
BUG 1:
We were not able to reproduce the issue, but we changed the tab selector logic and added some progress indicators, so it should be more informative to understand what happening there.
The fix is released in offline mode (v1.1.24), but soon will be released to the online mode too.
Thanks for reporting and sorry for the inconveniences.


#6

@erosdome @norbert Sorry on saying that the bug is easily reproducible! In 100% of the iPhone devices that I have access to (iPhone X, iPhone 6, iPhone 6s), and multiple iOS versions (iOS 11.3, iOS 11.0.1, iOS 10.3). Here is a video showing how it is impossible to access it on Safari (you can see in the address bar that I’m trying to interact with the page): https://www.dropbox.com/s/u85ykdk64i9e8zd/IMG_1203.TRIM.MOV?dl=1


#7

Also, it is not like it is a case of 1 minute or 2 (that can be solved with a progress indicator). I trimmed the video to 1 minute, but the view is not loaded at all.


#8

@erosdome Please, let me know when a new version is available on the website. Because, so far, all the bugs were closed, but none was solved.


#9

@norbert @erosdome I just tested using the latest version, and NOTHING was fixed.


#10

I re-created the GitHub issues:


#11

Hi @FWIgor,

I think we might have asked the wrong question or at least left out an important one: does it happen in every project or just in a single one / specific ones?

Can you please copy paste the related app’s bitrise.io URL, and enable Support Access (https://devcenter.bitrise.io/troubleshooting/enabling-bitrise-support-user/) to that app on the Settings tab? With that we could check that specific project directly.


#12

Every project that I have on Bitrise. @viktorbenei I have more 20 apps with the same problem. On ALL OF THEM.

Here are some examples:




#13

All the bugs reported, happens on all of them


#14

And does it happen in Chrome on the same iPhone?


#15

I don’t have Chrome installed on any device. And I would love not to have do to so.


#16

Got it - we’ll do our best to reproduce & fix the issue. Sorry for the inconvenience, we’ll let you know as soon as we have any update!


#17

I downloaded Chrome on iPhone X, and faced the scroll problem. Env vars view loads, but I’m unable to scroll. YML editor (for Mac) works on Chrome, but not on Safari. But, as I said, I don’t use Chrome, and hope to don’t be forced to install it only for Bitrise.


#18

Related cards re-opened in our internal issue tracker and bumped their priority. We’ll make sure that these are not closed until resolved - sorry for the inconvenience @FWIgor and thanks for all the details you provided!


#19

I personally could reproduce bug #3 you reported on a MacBook Pro. Strange that it only happens on specific ones, but it’s always reproducible on those ones. Same version of Safari and macOS, it works on my iMac as well as on most of our MacBook Pros, but on some the YML editor issue is reproducible :thinking:


#20

We have more than 10 MacBooks in the company. I managed to reproduce it in at least 10 computers. From late 2012 models, to current 2018 models.