Wait for Android emulator always failing

#1

Android TV device is never booted

I am trying to run the instrumented test for Android TV. Since there is no Android TV test device available on [BETA] Virtual Device Testing for Android step I can’t use it. After reading some articles I figure out there is possible to get an Android TV device configured by using both AVD Manager step and Wait for Android emulator step

Therefore, my first attempt was to use something like this:

Which AVD Manager step is 0.9.2 version and Wait for Android emulator step is 1.0.4 version. However, I am getting the error message below:

Waiting for emulator boot
> Checking if device booted...
Running command timed out, retry...
> Checking if device booted...
Failed to check emulator boot status, error: exit status 255

Also, I tried to downgrade the AVD Manager as mentioned here: Waiting for emulator to boot failes, but it’s still not working.

So, how can I fix this issue? My goal is to run instrumented tests for Android TV.

0 Likes