Unity Android App Build Error


#1

Description of the issue

I am now trying to build Unity Android App with bitrise, referring to the URL below.

However, when build is executed, the following Build log is output and an error occurs.

Environment:

Activate Unity(exit code: 1)

Hybrid(Xamarin,lonic …) on macOS,includes Visual Studio for Mac,Stable Channel
activate-ssh-key@4.0.3
git-clone@4.0.13
Unity-2018.2.18f1

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : YES
  • Does the issue happen sporadically, or every time? :every time
  • Does upgrading the build Step to the latest version help? : YES
  • When did the issue start? : 12/7

Local reproduction

Local reproduction: Linux / Android (docker based) stack builds

Build log

–Excerpt

LICENSE SYSTEM [2018129 19:38:15] License activated successfully with user: [REDACTED]

LICENSE SYSTEM [2018129 19:38:15] Next license update check is after 2018-12-11T03:38:14

[Package Manager] Server::Start – Port 55320 was selected
Launching external process: /Applications/Unity/Unity.app/Contents/Resources/PackageManager/Server/upm-macos

COMMAND LINE ARGUMENTS:
/Applications/Unity/Unity.app/Contents/MacOS/Unity
-quit
-batchmode
-serial
(hidden)
-username
[REDACTED]
-password
(hidden)
-logfile
Assertion failed on expression: ‘!projectPath.empty()’

(Filename: /Users/builduser/buildslave/unity/build/Editor/Src/ProjectUtility.cpp Line: 536)

Rebuilding Library because the asset database could not be found!

(Filename: /Users/builduser/buildslave/unity/build/Modules/AssetDatabase/Editor/Shared/AssetDatabaseInitialization.cpp Line: 108)

Audio: FMOD Profiler initialized on port 54900
FMOD initialized on nosound output
Loading GUID <-> Path mappings…0.000186 seconds
Loading Asset Database…0.000009 seconds
AssetDatabase consistency checks…0.000415 seconds
Refreshing native plugins compatible for Editor in 0.03 ms, found 0 plugins.
Preloading 0 native plugins for Editor in 0.00 ms.
DisplayProgressbar: Unity Package Manager
[Package Manager] Done resolving packages in 0.27s seconds
[Package Manager] Failed to resolve packages: [Packages] directory does not exist. No packages loaded.

A re-import of the project may be required to fix the issue or a manual modification of Packages/manifest.json file.
[Package Manager] Server::Kill – Server was shutdown


#2

Hello there!

Could you pease send us the url of the latest build please? so we can check the logs for additional information?


#3

Hi Fehersanyi-Bitrise,

here

As far as logs are concerned, I think that the part involved is only the part I extracted earlier.


#4

Since we do not use PackagerManager this time, we solved it by adding ‘- noUpm’ option.


#5

Hy @lynmock!

I’m glad you could solve it, and thanks for sharing the fix as well.


#6

Hi @lynmock,

Thanks for sharing your issue and the solution as well. I shall close this topic, but feel free to open a new one, should there be anything else you need help in! :slight_smile:


#7