Broken AVD system path after stack update

#1

Bitrise Build Issue Report template

Description of the issue

We have updated our stack to use a newer Xcode version (Xcode 11.4.x, on macOS 10.15.4 Catalina). Since then our Android UI-Tests failed with a timeout. The following error is new and probably the issue:
PANIC: Broken AVD system path. Check your ANDROID_SDK_ROOT value [/usr/local/share/[REDACTED]-sdk]!

Environment:

Where did the issue happen?

On Bitrise.io.

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? (Plus any other information you can share)

Stack: Xcode 11.4.x, on macOS 10.15.4 Catalina

Which build Step causes the issue and which version of the step?

Custom script V1.1.6

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : every time (since stack update)
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : It has started 3 days ago (since stack update)

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.
I can’t test it at my local maschine. But it worked with the previous stack and there were no other script/workflow changes.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ .
It’s a React Native setup which needs a Mac.

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - https://www.bitrise.io/contact ), with a link to the related Discuss issue.

0 Likes

closed #2

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes

#3

Hello @Sascha.Kuehne,
Can you share the contents of the script step you are using?

We are investigating adb path, it seems to be located at /usr/local/bin/adb at the moment. It is expected to be under /usr/local/share/android-sdk/platform-tools/adb but that is not the case.

0 Likes