In order to build my react-native app, I need the latest version of yarn. The one installed by default (v0.23.2) is too old, and triggers the error:
error @email@example.com: The engine "yarn" is incompatible with this module. Expected version ">=1.0.2". error Found incompatible module info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
I have tried upgrading it with npm (and also reinstalling it by downloading it via curl), but the old version is still the one being used. After upgrade/reinstall I have also tried to reload the shell, and then run yarn install manually from that bash script.
My build is running on Node v8.9.1 (through the NVM package). The build works fine locally.