"Unable to send build status back to GitLab" appears even when irrelevant

gitlab
website
step
git
#1

Hello!

In the past, we had been experiencing sporadic connection failures between Bitrise and GitLab, either when cloning a repo or when reporting the build status via the gitlab-status step. Usually, the affected steps will pass after a relaunch, which was tedious.

Today, it seems the actual connection issues are gone, but we’re still occasionally seeing this error in the UI:

Even when the logs show that the git-status step was successful (confirmed on GitLab). I thought it was related to Groups inside of groups on GitLab causes issues since our project is in a nested group, but nothing changed after I tried the workaround. Please also note that this error banner appears both on failed and successful builds.

Please let me know if you require more information to debug and correct this issue.

Thanks for a great service, and thanks for your time & attention. :slight_smile:

0 Likes

#2

…And just a few minutes later, I noticed the problem. The “Service Credential User” was suddenly missing from our projects after “someone” (:raised_hand:) accidentally removed and re-added said account to the organization right around the same time the issue started. :man_facepalming:

I re-connected the service account user to each project, and the issue seems solved—I’ll reopen within the next couple of days if it’s somehow not the case. (It’s still a bit mysterious that the status was updating regardless of this missing configuration. :thinking::man_shrugging:)

Sorry for the noise/monologue, but maybe this will help someone else anyway!

0 Likes