Set set-java-version@1 on local Bitrise CLI


While running bitrise client on local mac machine with m1 I’ve got:

e[0m- JavaVersion: 11

e[34;1mChecking platforme[0m
Platform: MacOS

e[34;1mRunning platform specific commands to set java versione[0m
$ jenv "global" "11"
jenv: version `11' not installed

e[34;1mGlobal java & javac versions the after the command rune[0m
$ java "-version"
openjdk version "11.0.15" 2022-04-19
OpenJDK Runtime Environment Homebrew (build 11.0.15+0)
OpenJDK 64-Bit Server VM Homebrew (build 11.0.15+0, mixed mode)

$ javac "-version"
javac 11.0.15
e[31;1mexit status 1e[0m
|                                                                              |
| e[31;1mxe[0m | e[31;1mset-java-version@1 (exit code: 1)e[0m                             | 2.92 sec |
| Issue tracker: |
| Source:     |

but when I’m running in terminal “jenv versions” here’s what I got:

jenv versions
* 11.0 (set by /Users/username/.jenv/version)

Changing input version in bitrise.yaml from 11 to 11.0 it does not help since then I’ve got:
"failed to parse config:

  • JavaVersion: 11.0: value is not in value options (opt[11,8])"

Is there some fix to that? Or maybe I’m doing something wrong?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.