Cocoapods failing after adding plugins cocoapods-binary and cocoapods-static-swift-framework


Bitrise Build Issue Report template

Description of the issue

Please describe the issue here
Cocoapods failing after adding plugins cocoapods-binary and cocoapods-static-swift-framework.
It works on my local machine. I tried bitrise cocoapods install step and fastlane cocoapods. Both fail.


Where did the issue happen?
xcode 11.1

Which build Step causes the issue and which version of the step?
Cocoapods Install 1.9.1


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : Everytime
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : after adding plugins cocoapods-binary and cocoapods-static-swift-framework

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Tried first section. It succeeds locally

Build log



Hi @iarpits!

Sorry for our silence on your report. Can you please contact us about this on our on-site chat or via e-mail instead? Seems like an issue we’d need temporary access for to debug properly.


closed #3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.