Parallel execution is an incubating feature

Bitrise Build Issue Report template

Description of the issue

The build fails on a step install-missing-android-tools@2.2.0 with exit code: 1. I’ve tried the local build from cloned repo using Gradle assemble and it worked. The issue started a few days ago and it appears on different branches that were changed independently. I can’t define the piece of code change that causes this exception.


Ubuntu 18.04. The issue happens during install-missing-android-tools@2.2.0


  • Rebuilding does not help
  • Rebuild without caches does not help (I excluded caches steps from the workflow)
  • The issue happens every build/rebuild
  • It’s the latest version of the step
  • It started a few days ago

Local reproduction

It can’t be reproduced locally because this step is not required for local builds. It gets skipped.

Build log

Link to the build:


The same workflow step works fine for another workflow of the same branch. E.g.: I’ve tried 1st workflow that has the same step install-missing-android-tools@2.2.0 and it finished successfully. Then I’ve tried another workflow for the same commit and it failed.

Hi @p.val!
Sorry to hear about the issue.

Thanks for contacting us here, we’ll look into it and ger back to you ASAP!

Adding the solution here also: The solution was to make sure that there was a default versionCode and versionName set in the build.gradle file as the build was picking up these and started failing for PR builds. Usually the default values would look like:

versionCode 1
versionName “1.0”

1 Like