Nvm step not working

Bitrise Build Issue Report template

Description of the issue

I have an nvm step that doesn’t appear to be working fully.

In the nvm step, I request node 10.6.3

Then I have an script step that runs this verifying that nvm worked:

++ node -v
+ echo 'node = v10.16.3'
node = v10.16.3
++ npm -v
+ echo 'npm = 6.9.0'
npm = 6.9.0

However, when I log remotely into the VM to debug, I get these:

prd-std-r-xcode-11-3-200113195648-57qPrAcwCbi8FRDe9Aw7GL:git vagrant$ node -v
prd-std-r-xcode-11-3-200113195648-57qPrAcwCbi8FRDe9Aw7GL:git vagrant$ npm -v

Not having the correct version of node is causing my build to fail.


Where did the issue happen?

The Xcode 11.3 macOS 10.14.6 stack

Which build Step causes the issue and which version of the step?

nvm - version: 1.2.2


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. NO
  • Does the issue happen sporadically, or every time? : Sporadically
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : Last week

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.


Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( Bitrise CLI )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: Redirecting… .

Build log

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.