Minimal example for macOS with Scons build system

Hi community!

I’have this workflow on travis that I want to replicate on bitrise using a .yml file.

Could someone please share a minimum example that I can use to run the macOS build using Scons.

I’d like to get this thing up and running as quickly as possible, and expand from there, rather than reading a bunch of docs with options and specs that I might never use.

Any comment is appreciated… Cheers!

Hi @rraallvv,

I’d suggest you to just generate a base bitrise config then iterate on that, adding the things you need.

Using the Bitrise CLI (https://www.bitrise.io/cli) you can generate a base config by:

cd /into/your/git/root
bitrise init --minimal

The minimal config will include a Script step. You can do anything with the Script step, e.g. running the commands you ran in your travis config.

Please see a practical intro to the CLI and editor at: How to experiment with Bitrise configs locally, on your Mac/Linux

If you’d have any questions just let us know! :slight_smile:

@viktorbenei Thanks, I appreciate it a lot.

1 Like

I installed the CLI tool like this:

brew update && brew install bitrise

But then got this error:

$ bitrise init --minimal
FATA[12:59:34] Plugin (init) not installed

Also tried the setup command but somehow bitrise wasn’t able to connect

$ bitrise setup

  ██████╗ ██╗████████╗██████╗ ██╗███████╗███████╗
  ██╔══██╗██║╚══██╔══╝██╔══██╗██║██╔════╝██╔════╝
  ██████╔╝██║   ██║   ██████╔╝██║███████╗█████╗
  ██╔══██╗██║   ██║   ██╔══██╗██║╚════██║██╔══╝
  ██████╔╝██║   ██║   ██║  ██║██║███████║███████╗
  ╚═════╝ ╚═╝   ╚═╝   ╚═╝  ╚═╝╚═╝╚══════╝╚══════╝

  version: 1.11.0

Setup
Full setup: false
Clean setup: false
Detected OS: darwin

Checking Bitrise Core tools...
No supported envman version found
You can find more information about envman on its official GitHub page: https://github.com/bitrise-io/envman
Installing ⣟Download failed, retrying ...
Installing ⣟

Is there a verbose option to see if there is an error somewhere?
Could you please point me where to find information on how to I install or update to the repo’s version?

Thanks.

Installing ⣟Download failed, retrying

Can you please try to run bitrise setup again? It seems you had some network issues, most likely.

One more thing, if you had a previous CLI version installed and you want to do a full, clean setup you can do:

bitrise setup --clean

Or manually:

rm -rf ~/.bitrise
bitrise setup

That said this is pretty much never required, just wanted to mention as a “last resort” solution.

@viktorbenei I tried again with a more stable internet connection, and now everything works fine. Thanks for your help and all the information, I appreciate it a lot.

1 Like

Glad to hear @rraallvv! :wink: